cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
New Member

GMail connector won't save advanced options

I'm trying to set up a simple flow to post a Slack message when I receive an email from a specific person through a GMail business account.  

 

When I set up the GMail connector and put the email address in the From field of the advanced options, it won't persist the address.  It disappears even after I save the flow.  The result of course is I get the Slack notice on all incoming email rather than the one person I want.

 

Anyone have an idea what the problem might be?  Thanks in advance.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Super User
Super User

Re: GMail connector won't save advanced options

@Arghknork 

 

I was able to replicate your issue, by entering in a not valid email in the From field.

 

I was able to get it to work by entering a valid email in the From field. You will know if the email is valid as it will show up like this:

 

Please note, after you type the email in you MUST press enter key

 

pic1.png

 

Hopefully this helps





Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up ?


Proud to be a Flownaut!





View solution in original post

8 REPLIES 8
Highlighted
Super User
Super User

Re: GMail connector won't save advanced options

Hello @Arghknork 

 

What happens if you put the email address inside a variable or a Compose action. And reference that action in the form field.

 

Try to delete the action and re add.





Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up ?


Proud to be a Flownaut!





Highlighted
New Member

Re: GMail connector won't save advanced options

Please forgive a dumb question, but I'm just getting started.  I want a flow that starts with a trigger of an email received, using the GMail connector.  How can I specify a variable before the trigger so I can use it in the GMail connector?  Unless I'm missing something, the trigger must be the first.  Thanks.

Highlighted
Super User
Super User

Re: GMail connector won't save advanced options

@Arghknork 

Sorry, that is my mistake. I misread your post.

 

hmm this is weird. Since you say the connection that is being used is a business account. It should work as expected.


Can you try and create a new flow. And see if problem persists.





Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up ?


Proud to be a Flownaut!





Highlighted
New Member

Re: GMail connector won't save advanced options

I've deleted and recreated the flow several times with the same results.  It's very simple with a GMail connector for the trigger and a Slack connector for the action.  It works great, but sends a Slack notice for every incoming email in Inbox since I can get the From advanced option field to persist.

Highlighted
Super User
Super User

Re: GMail connector won't save advanced options

@Arghknork 

 

Could you post a screenshot of your trigger with an attempt of adding an email address to the From field, before saving.

 

Thanks





Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up ?


Proud to be a Flownaut!





Highlighted
New Member

Re: GMail connector won't save advanced options

It's pretty straight forward.  I start with nothing in the advanced options.  Notice also, no suggested people.  I know it's properly authorized to GMail because I can get a dropdown that shows me the mailbox folders in that account.

 

Capture1.JPG

 

I enter the email I want to filter for in the From field.  I click Save and the email remains in the From field ...

 

Capture2.JPG

 

Then, if I collapse the control and re-expand it and click Show advanced options, the fields are all blank again ...

 

Capture3.JPG

Highlighted
Super User
Super User

Re: GMail connector won't save advanced options

@Arghknork 

 

I was able to replicate your issue, by entering in a not valid email in the From field.

 

I was able to get it to work by entering a valid email in the From field. You will know if the email is valid as it will show up like this:

 

Please note, after you type the email in you MUST press enter key

 

pic1.png

 

Hopefully this helps





Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up ?


Proud to be a Flownaut!





View solution in original post

Highlighted
New Member

Re: GMail connector won't save advanced options

@Jcook , you're awesome!  I've done this so many times I know for a fact I had a good GMail account and a valid email address.

 

It turned out to be the ENTER key.  I wasn't hitting ENTER, and doing that made it keep the address.

 

Thanks for all the help!

Helpful resources

Announcements
firstImage

Now Live: Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Top Kudoed Authors
Users online (8,318)