cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
batvan276
Helper II
Helper II

Get File Content Using Path - Null Content?

Hello, 

 

I thought I had this working at one point but just tried to test it and I can't seem to see what I am getting wrong. Did I miss something? I Keep getting cannot be null content error message. (Parameter 'Attachment Content' cannot be null or empty.)

 

batvan276_0-1614025374135.png

 

 

 

2021-02-22_15-24-54.png

 

 

 

 

 

 

batvan276_2-1614025395050.png

 

 

2 ACCEPTED SOLUTIONS

Accepted Solutions

Same Issue ; 

 

batvan276_0-1614170715125.png

 

batvan276_1-1614170723856.png

 

batvan276_2-1614170752039.png

 

batvan276_3-1614170761524.png

 

View solution in original post

Click [Next faild] to find the failed email sending action.
And how many emails with attachments have been received. Then find out which file is not attached.

 

There are 3 files in the document library, and if all are successful, the mail will be sent 3 times.
If it fails all three times, I think there is a problem with the flow, but looking at the posted image, the first file seems to have been successfully attached to an email.

 

Since there are both successful and unsuccessful actions in Apply to each, I think it's not a flow problem, but a problem with the file you're dealing with.
Delete the failing file from the document library and try the flow again.
So if you don't get the error, there is a problem with the deleted file.

 

--------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

View solution in original post

7 REPLIES 7
Masa_
Helper I
Helper I

I think it will succeed if you set [File Path] in the [Get file content using path] action to [FullPath] instead of [Link to item].

I used google translate.

Regards,

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

 

Masa

I tried that but received same error message.

Is the source of this trigger a document library? Or is it her list in SharePoint?

If it's a document library, try testing a simple flow with a manual trigger like this: In my environment, I was able to attach the document library file to an email and send it without any errors.

2021-02-24_09h58_55.png

 

 

If it is a list, you need to get the contents of the attachment using two actions as below.

2021-02-24_11h21_45.png

 

2021-02-24_11h21_55.png

 

2021-02-24_11h22_04.png

 



--------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Yes this source is a a document library. I will try your suggestion. 

Same Issue ; 

 

batvan276_0-1614170715125.png

 

batvan276_1-1614170723856.png

 

batvan276_2-1614170752039.png

 

batvan276_3-1614170761524.png

 

View solution in original post

Click [Next faild] to find the failed email sending action.
And how many emails with attachments have been received. Then find out which file is not attached.

 

There are 3 files in the document library, and if all are successful, the mail will be sent 3 times.
If it fails all three times, I think there is a problem with the flow, but looking at the posted image, the first file seems to have been successfully attached to an email.

 

Since there are both successful and unsuccessful actions in Apply to each, I think it's not a flow problem, but a problem with the file you're dealing with.
Delete the failing file from the document library and try the flow again.
So if you don't get the error, there is a problem with the deleted file.

 

--------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

View solution in original post

Everything worked out. Sorry about that. 

 

I was testing the flow using an old trigger of a file that was already deleted. 😓

 

 

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Users online (90,817)