cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
vidhi_vaish03
Regular Visitor

Getting Unauthorized 401 error while sending patch request to Azure devops

Hey,

 

I have been trying to auto assign workitems in azure devops and every time i am sending an http request to Devops i get Unauthorized 401 error. I can create a work item in the same directory when doing it directly from ADO and can even create a work item using power automate connectors but the http request is not working. 
Any solution?

vidhi_vaish03_0-1630664485144.pngvidhi_vaish03_1-1630664515016.png

 

1 ACCEPTED SOLUTION

Accepted Solutions
Expiscornovus
Dual Super User
Dual Super User

Hi @vidhi_vaish03,

 

Can you try the example below.

 

updateassignedto.png

View solution in original post

6 REPLIES 6
Expiscornovus
Dual Super User
Dual Super User

Hi @vidhi_vaish03,

 

Can you replace the HTTP action by the Send an HTTP request to Azure DevOps action:

https://docs.microsoft.com/en-us/connectors/visualstudioteamservices/#send-an-http-request-to-azure-...

 

sendanhttprequestdevops.png

 

If this approach doesn't work can you share a bit more details of which PATCH request you are trying to send? (Uri, body, etc.)

Hey!

 

I have been trying to auto update a work item whenever it is created.

The only thing i want to do is to auto assign work items to a specific person when ever a work item gets created.

If there is any other way possible for this other than HTTP Request it will be great !

 

Maybe I am not able to get authorization correctly for this HTTP Request.

 

Tried using "Send a http request to Azure DevOps but now receiving different sought of error but is still un authorized 

This is my request.

vidhi_vaish03_0-1630680797977.png

 

This is the error I am getting

 

vidhi_vaish03_1-1630681078736.png

 

Expiscornovus
Dual Super User
Dual Super User

Hi @vidhi_vaish03,

 

Can you try the example below.

 

updateassignedto.png

vidhi_vaish03
Regular Visitor

Hey!

 

This works! Thanks a lot! Its like magic. 

Many thanks.

Hey @Expiscornovus 

I hope you would be able to help with my problem where I am trying to upload attachments from SharePoint. But ended up in same error. Your help is really appreciated...!

issac_franklin_0-1654176369053.png

 



Expiscornovus
Dual Super User
Dual Super User

Hi @issac_franklin,


Yes, I (or another member of the community) can help out with this. Can you start a separate thread for this?

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Power Automate Designer Feedback_carousel.jpg

Help make Flow Design easier

Are you new to designing flows? What is your biggest struggle with Power Automate Designer? Help us make it more user friendly!

Users online (2,731)