cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
New Member

Graph API is unable to open the workbook

I have created the simple test Sharepoint workflow via Power Automate but this will prompt '

'Graph API is unable to open the workbook' error while I add the feature of 'List rows present in a table'. 
 
Have anything wrong of my situation or this is blocked access with Microsoft?
 
Workflow_2.PNG
7 REPLIES 7
Dual Super User II
Dual Super User II

Hi @Kaho 

 

Can you check and confirm that the excel file you are trying to access form Power Automate is not open in the browser or checked out by any user? 

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Hi Yashag,

 

Thanks for your kindly uppdate information.

 

I have confirm that the excel file is not open in the browser and checked out by other users as this is set to private only.

Dual Super User II
Dual Super User II

Hi @Kaho 

 

Can you try creating a single step flow that is manual trigger and list rows present in a table?

 

Can you try selecting the file and the table from the folder icon and the dropdown respectively instead of typing in a manual value and try once? 

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Hi Yashag,

 

I'm already using single step flow for manual tigger and list rows present in a table.

 

But while I selected the excel file, the 'table' will not dropdown anything and prompt 'Could not retrieve values, graph GPI is unable to open the workbook'workflow_3.PNG

Hi @Kaho , did you have any success in resolving this? I am encountering the same issue and our IT team can't figure it out...

Advocate I
Advocate I

Hi All,

 

I have just been working on this issue, what fixed it for me was to completely delete the connector, Data (on the left) -> Connections -> three dots next to the excel online connector and delete. It warns of the flows that are using it, make a note and delete the connector.

 

Now open a flow that was using it and go to the action with the issue. Click the three dots in the top right and instead of clicking on fix connection, create a new one. Sign in as normal. Then test again.

 

Hope this helps.

Hi Robcc,

 

Your workaround acticle is work.

 

Thanks very much.

 

 

Helpful resources

Announcements
Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

Microsoft Ignite

Microsoft Power Platform: 2021 Release Wave 1 Plan

Power Platform release plan for the 2021 release wave 1 describes all new features releasing from April through September 2021.

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Users online (71,933)