cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Laura_Amber
New Member

Group list email in approval flow

I am creating approval workflow and instead of personal email I want to use group list, but when I add it, nobody receives it. What can you suggest ?

6 REPLIES 6
v-xida-msft
Community Support
Community Support

Hi @Laura_Amber,

 

Do you want to type a group email address within Assigned to field of "Start an approval" action?

 

The group email address is not supported in Assigned to field of "Start an approval" action within Microsoft Flow currently, the Assigned to field only support specific personal email address.

 

If you want to send the approval email to multiple approvers, you could consider type multiple approvers' email address within Assigned to field and separated by a semicolon (;) .

 15.JPG

In addition, if you would like this feature to be added in Microsoft Flow, please submit an idea to Flow Ideas Forum:

https://powerusers.microsoft.com/t5/Flow-Ideas/idb-p/FlowIdeas

 

Best regards,

Kris 

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

It's a little annoying, but you can do these actions:

  1. Use Initialize variable to create a blank string called emailList.
  2. Use List group members to get the Office 365 group (or you could do it with an Azure AD group, too)
  3. Use Append to string variable to update your emailList variable. Flow should automatically create an "Apply to each" loop for you - just put in the Value of Mail, followed by a ";"
  4. Use Start an approval assigned to your emailList variable.

Microsoft Flow - assign approval to group

Anonymous
Not applicable

Hello, I tried your solution but it doesn't work. I got an error message in the "Start an approval" : BadRequest. The request failed. Error code: 'InvalidApprovalCreateRequestAssignedToMissing'. Error Message: 'Required field 'assignedTo' is missing, empty, or contained no valid users.'.

 

Can you explain ?

 

Thank you

It worked for me. You might have to include the semicolon in your string. I did this in the Append to string variable step. *Value "[Mail] ;"

Hi

 

Any easier solution. I also have a library with a People picker column called "Assigned to:" but getting the same errors

 

Thx

Linda

I am trying to use the 'feature to be added' link provided, but I get a message that I don't have sufficient privileges... Any idea why?

Helpful resources

Announcements
MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Users online (68,224)