cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Buddy2019
Helper I
Helper I

HTTP Post Request with parameters inside JSON Schema

I am trying to a send a HTTP Post request with some parameters in the JSON Schema.

 

PostPost

However, when this request is triggered, I get this error 

{"error":{"code":"TriggerRequestMethodNotValid","message":"The HTTP method for this request is not valid: expected 'Post' and actual 'GET'."}}

 

I notice that it is always sending a GET request even if I sent a post method.  How would I be able to send a Post request? I am trying to send some parameters within the body. I don’t want my parameters to be visible in the URL.

 

Get.png

1 ACCEPTED SOLUTION

Accepted Solutions
yashag2255
Dual Super User II
Dual Super User II

Hey @Buddy2019 

 

So you can do that by not defining any particular type while configuring the trigger. All you need to do is configure the JSON schema for the request. I have written this blog post that can help you with the entire configuration: 

https://powerusers.microsoft.com/t5/Microsoft-Flow-Community-Blog/Microsoft-Flow-as-a-Service/ba-p/3... 

 

You might wanna check this thread as well: 

https://powerusers.microsoft.com/t5/General-Flow-Discussion/Trigger-a-HTTP-Request-via-URL/m-p/36473...

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

2 REPLIES 2
yashag2255
Dual Super User II
Dual Super User II

Hey @Buddy2019 

 

So you can do that by not defining any particular type while configuring the trigger. All you need to do is configure the JSON schema for the request. I have written this blog post that can help you with the entire configuration: 

https://powerusers.microsoft.com/t5/Microsoft-Flow-Community-Blog/Microsoft-Flow-as-a-Service/ba-p/3... 

 

You might wanna check this thread as well: 

https://powerusers.microsoft.com/t5/General-Flow-Discussion/Trigger-a-HTTP-Request-via-URL/m-p/36473...

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

Hey @Buddy2019 

 

Were you able to resolve? If this issue is resolved, please mark the response that helped you as 'Accept as Solution'. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Helpful resources

Announcements
User Groups Public Preview

Join us for our User Group Public Preview!

Power Automate User Groups are coming! Make sure you’re among the first to know when user groups go live for public preview.

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

Power Platform ISV STudio

Power Platform ISV Studio

ISV Studio is the go-to Power Platform destination for ISV’s to monitor & manage applications post-AppSource publish.

Users online (77,896)