cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
AndrewGeddes
Helper II
Helper II

Help Needed: Copy file on multiple approvals failing

Hi everyone,

 

Apologies in advance if this has been answered - can't figure out where I'm going wrong.

 

I've got a fairly simple flow: when a file is created or modified within a folder, it triggers the flow. Starts an approval with 4 people requiring approval from everyone. Once approved, it copies file to parent directory in library for all to see.

 

The problem is I'm getting the following error when the workflow arrives at Copy File: ActionBranchingConditionNotSatisfied.  Any ideas?Capture.PNG

1 ACCEPTED SOLUTION

Accepted Solutions

Hi @ AndrewGeddes,

 

Could you please modify the "approve" in your Condition to "Approve" as me?

The first letter of the value "Approve" should use capital letters.

 

Regards,
Alice Zhang

View solution in original post

4 REPLIES 4
v-yuazh-msft
Community Support
Community Support

                                                                   

Hi @ AndrewGeddes,

Could you please show a screenshot of the details of the “Start an approval” action and the “Condition” in your flow.

The message told that the “Create file” action has skipped because the result of the Condition is “false”. Perhaps this message isn’t error message, because as long as there is one person reject the file, the approval’s response would be “Rejecte” , and the flow would run the “If no” branch of the Condition.

 

I have made a test on my side and I don't have the issue that you mentioned.

Please refer to screenshots below:

 1.png

 

Please make sure:

  1. The four people in the “Assigned to” field all approve the file.(Note: As long as there is one person reject the file, the result of the approval would be Rejected.)
  2. The Condition’s first value set to the “Response” dynamic content in the of “Start an approval” action, the second value set to “Approve”, the condition in the middle select is equal to.

 

When the people in the “Assigned to” field all approve the file, the flow would run successfully as below:

2.png

 

And the file would be created in the new path of sharepoint library as below:

 3.png

 

 

 

 

Regards,
Alice Zhang

@v-yuazh-msft Alice, thank you so much for the response.  I'm not sure where I'm going wrong here. I have only myself as approver currently until I get this working, then will be assigning to the 4 folks who will actually do approving. Please take a look and see if I'm missing something?

 

Flow Config.PNGFLow Fail.PNG

Hi @ AndrewGeddes,

 

Could you please modify the "approve" in your Condition to "Approve" as me?

The first letter of the value "Approve" should use capital letters.

 

Regards,
Alice Zhang

View solution in original post

AndrewGeddes
Helper II
Helper II

Well that is a terrible embarrassment! Thank you for pointing it out, I've been looking at it for days with no luck. Really appreciate the help!

Helpful resources

Announcements
MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Users online (56,100)