cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
JoeQuick
Frequent Visitor

How do you add an attachment

there no dynamic content of "content" to add.

 

 
 
6 REPLIES 6
jinivthakkar
Super User
Super User

please share more details or screenshot

Sorry about that, kept giving me errors when i tried to save with pics.

Screenshot 2021-01-16 105322.jpgScreenshot 2021-01-16 104107.jpg

 

Theres no option to add content in dynamic content window to put in the Attachment content

Hi @JoeQuick 

 

You can use the SharePoint "Get File Content" action pass it the "Identifier" Note: - Identifier it the output of the "Get file Properties" action.

 

CFernandes_2-1610873016934.png

 

 

CFernandes_1-1610872875786.png

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

 

 

JoeQuick
Frequent Visitor

This doesnt make sense to me cause im stupid.

Some time it works, and sometime it doesnt.

I already had that in my flow.

Screenshot 2021-01-17 192938.jpg

Example: This will attach a file to an email, and attachment will open, without using.Screenshot 2021-01-17 191258.jpg

Screenshot 2021-01-17 190940.jpg

And other times it wont 

Attachment wont openAttachment wont open

 

Both have Finlename and file content.

Why cant any sharepoint file be attached to an email is what I can wrap my head around. Why do i need to specify a content ?

What connectors/triggers do I need to achieve this.

Is there anywhere that has a list of what connectors/triggers has what kind of Dynamic content are available to use in the flow?

 

OK I added the Get file content. Now the flow fails before it get the chance to send the email,

Screenshot 2021-01-17 193509.jpg

Screenshot 2021-01-17 193844.jpgScreenshot 2021-01-17 193837.jpg

Hey @JoeQuick ,

 

The Error is "NotFound",so Power Automate cannot find the file. Check if the file exist in your SharePoint. 

 

Also, you would need to use the "Get file properties" first and then the "Get file content". Please make sure that that file exist and that actions are sequenced correctly.

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

 

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Users online (2,383)