cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Helper I
Helper I

How long does it normaly takes until a flow run after trigger

Hi all,

 

I´ve  set up a  flow , with a "When a new item is created" trigger and it takes about 5 min until the flow starts to run.

Is this the standard behaviour?  If I open the flow and save it, the flow will run immediately.

Is there any chanche to speed up the start?

 

 

 

 

3 REPLIES 3
Dual Super User III
Dual Super User III

Hey @Chriss1982 

 

There could be 2 reasons that I can think of for this: 

1. The license plan that you are enrolled to. Now based on the recent changes, to run flows more frequently you need to have premium plans. You can check the recurrence in the flow trigger by doing a peekcode on the flow trigger and find the recurrence property and check what is the time set over there. 

2. Can you confirm that after modifying the item (if being manually done) you are actually hitting the save button? 

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Hey @yashag2255 ,

 

thanks for your answer.

 

this contains the peekcode of "When a new item is created":

 

"recurrence": {
        "interval": 5,
        "frequency": "Minute"
    }

So I guess this means, it runs every 5 minute. Is this right?

Would it be faster if I had "premium plans"?

 

 

 

 

Hey @Chriss1982 

 

Yes. You are right. The flow licensing has changed and that changes the way triggers behave. You can run faster and more frequent flows with upgraded plans. But now as the licensing has changed to per flow or per user plan, you can run faster and frequent flows and then upgrade once you exhaust the number of runs. More information on this can be found here: https://go.microsoft.com/fwlink/?LinkId=2085130&clcid=0x409%20 and on license upgrades here: https://us.flow.microsoft.com/en-us/pricing/

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Users online (7,819)