cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

How to add Power Automate to Power Virtual Agents

I Create a Power Virtual Agents. The thing is when a customer type his Order Number in the chatbox then I want to check the Order Number automatically in my SQL database. I think I need to create a variable then create a FLow (Power Automate), but unfortunately I don`t see any flows when I click on Action in Power Virtual Agents.

PVA.png

The only example I can find on internet is how to send an email with HTTP something. 

 

Could you guys please tell me how fix this?

 

Thanks in advance! 

1 ACCEPTED SOLUTION

Accepted Solutions

Hey @Anonymous 

 

This is weird. There is no reason it should behave like that. Now can you try this: 

1. Create a new solution and create a new flow from scratch in this solution? You need to have atleast one input and one output key in the flow (something like that video)

 

Just a small one to check if there is no issue from the Power Automate side. 

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

10 REPLIES 10
yashag2255
Dual Super User II
Dual Super User II

Hey @Anonymous 

 

You can check my blog here where I have done something like that with SharePoint actions in a Flow. You need to have the trigger in flow as "When an HTTP request is received" and structure the json accordingly. More here:

 

https://www.bythedevs.com/post/getting-started-with-ms-power-virtual-agents-on-the-powerplatform

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Anonymous
Not applicable

Hi @yashag2255 ,

 

Thanks for your response! Below I created a Flow similar like you did, But unfortunately I still don`t see the Flow in my Power Virtual Agents. I can save the Flow without any error. I refreshed bot multiple times but is doesn`t help. I don`t know what I am doing wrong.

 

PVA.png

Hey @Anonymous 

 

A few things: 

1. Ensure that the flow is in the same environment as your bot is in. 

2. Ensure that the flow is in a solution. 

 

I can see that at the end, your response action just has a string. make that as a key: 

e.g.;

{

"response" : "whatevertext"

}

 

Copy the entire thing and use it to generate the schema. 

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Anonymous
Not applicable

Hi @yashag2255 ,

 

I tried that too. I created the Flow and the Power Virtual Agents in the same environment with the same email address.

 

As you can see the Flow is also created in Solution. I really don`t why it doesn`t show my Flow in Power Virtual Agents.

1.png

 

Thanks in Advance!

Hey @Anonymous 

 

You might want to closely follow this video here once to check if you are not missing any minor steps. https://www.youtube.com/watch?v=joXCzvi38Fo&feature=youtu.be

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Anonymous
Not applicable

Hi @yashag2255 ,

 

Thank for your response! I swear I followed the steps as it mention in the video.  I really don`t understand why it doesn`t appears in my Action in Power Virtual Agents. 

 

- I use the same environment (I only have one environment) 

- I created the Flow in Solution Area as you can see in my previous message

- The Flow that I created is turn on and has not error bij Flow checking

- I refreshed both Power Automate and Power Virtual Agents still does not appears my Flows

 

3.png

Thank you for your help! 

Hey @Anonymous 

 

This is weird. There is no reason it should behave like that. Now can you try this: 

1. Create a new solution and create a new flow from scratch in this solution? You need to have atleast one input and one output key in the flow (something like that video)

 

Just a small one to check if there is no issue from the Power Automate side. 

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

Anonymous
Not applicable

Hi @yashag2255 ,

 

Thank you for your help! It finally works! I think the problem is I typed the schema in the body manually, but the thing is you have to write in (Response Body JSON Schema).

 

 

Anonymous
Not applicable

Hi @yashag2255 ,

 

I have another question about Power Automate in Power Virtual Agents. Maybe you can help me again, for more details see you link below.

 

https://powerusers.microsoft.com/t5/General-Power-Automate/Question-about-Power-Automate-in-Power-Vi...

 

Thanks in advance!

An updated doc with a deeper example of how to us e Power Automate flows with Power Virtual Agents was published recently here:

https://docs.microsoft.com/en-us/power-virtual-agents/advanced-flow

 

It looks into details on how HTTP Response should be build properly, including filling out both Response schema and Body.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Users online (3,349)