cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
bhrigu12
Advocate III
Advocate III

How to attach files from sharepoint list items to approval mail notification?

Hi everyone,

 

I have been working Approval flow mail but i am unable to attach files from sharepoint list to approval mail. Screen shots are given, Can anyone help?

Expression for "ContentBytes": body('GetAttachmentContent')?['$Content']

 

1st part1st part

Screenshot 2020-04-15 at 12.00.15 PM.pngScreenshot 2020-04-15 at 11.40.10 AM.png

1 ACCEPTED SOLUTION

Accepted Solutions

@efialttes 

Hi,

i got the solution the problem was with "ContentBytes". In Approval mail system content key is required and not contentbytes. Now my flow is working fine...

Thnx for the help!!!

View solution in original post

6 REPLIES 6
efialttes
Super User
Super User

Hi!
So in your append to array you currently assign the DisplayName from Dynamic content menu, retrieved from “Get Attachments” action to the Name property... why don't you do the same with 'Content bytes' property and assign as its value the Attachment Content from Dynamic content menu, retrieved also from “Get Attachment Contents” action?
Hope this helps


Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



Hi,

Actually the flow is getting terminated in condition stage only and the condition always flows through No..... Screenshot attached.

 

Screenshot 2020-04-15 at 12.40.21 PM.png

Ooops!
You are right, this seems to be the problem!
My suggestion is, to replace YES and add the following expression from dynamic content menu instead:
true

Hope this helps


Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



HI @efialttes ... Thnx for replying..

 

The flow is working now but without any attachments... 😞

As was suggested i had even replaced ContentBytes expression with Attachment Content from Dynamic content menu, retrieved also from “Get Attachment Contents” action.... still no luck...!!

 

 

Hi!
I guess you followed the recommendations on how to add attachments to an Approval, right?
https://docs.microsoft.com/en-us/power-automate/approval-attachments
Hooe this helps


Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



@efialttes 

Hi,

i got the solution the problem was with "ContentBytes". In Approval mail system content key is required and not contentbytes. Now my flow is working fine...

Thnx for the help!!!

View solution in original post

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Users online (2,949)