cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

How to find out what User completed a Planner task?

I am trying to post a message in Teams to show that a specific task has been completed by the user who closed a Task in Planner. Does anyone know the variable I can use to accomplish this? Currently there is no content for user who completed a task. 

Snag_1571cece.png

 

1 ACCEPTED SOLUTION

Accepted Solutions

Hi @seanpcoa !

If I am correct, you are using multiple triggers in your Flow. It is most likely that 'triggerBody()' only works for the first trigger in the whole Flow. So you are basically trying to find this value triggerBody()?['completedBy']?['user']?['ID'] in a bad triggerBody. Of course it isn't there (well it is, but the path is diferent and the value is NULL), so hence goes the error. I can't think of a solution to this now, because I am quite busy, but you can definitely make it work if you only use one trigger action per Flow 🙂

Cheers and GL!

View solution in original post

22 REPLIES 22
vecerpa
Memorable Member
Memorable Member

Hi @Anonymous,

Btw nice nickname 🙂

The planner connector as I see is in preview mode, so there is possible change in future.

 

Right now I see that there is only option to get person who completed task in planner by MS Graph API. There is option to get task by id 

GET /planner/tasks/<id>

In response there is part:

"completedBy": {
        "user": {
            "displayName": null,
            "id": "459cf522-d52d-4c47-a41a-cfa9874ed226"
        }
    },

And then get user by this id

GET /users/{id | userPrincipalName}

And you will receive response with user details.

Here is a link with description how you can register app and run API request, but you will need tenant admin rights for this  -https://gotoguy.blog/2017/12/17/access-microsoft-graph-api-using-custom-connector-in-powerapps-and-flows/

 

And also don't forgot to place this to Ideas blog - https://powerusers.microsoft.com/t5/Flow-Ideas/idb-p/FlowIdeas, if not already there.

P.

v-xida-msft
Community Support
Community Support

Hi @Anonymous,

 

Could you please share a screenshot of your flow's configuration?

Do you want to include the user who completed the Planner task into the message sent to your Microsoft Teams channel using Microsoft Flow?

 

I agree with @vecerpa's thought almost. Getting the user who completed the Planner task is not supported in Planner connector of Microsoft Flow currently, if you would like this feature to be added in Microsoft Flow, please submit an idea to Flow Ideas Forum:

https://powerusers.microsoft.com/t5/Flow-Ideas/idb-p/FlowIdeas

 

In addition, you could consider take a try with the solution the user @vecerpa mentioned. Please also check if the following article would help in your scenario:

https://sergeluca.wordpress.com/2017/09/22/extend-microsoft-flow-with-the-microsoft-graph-and-0-code/

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

Hi @v-xida-msft

 

Thanks for the reply! Here is the top part of the flow. From Planner I am simply pulling "When task is completed" filtering an if statement by a specific title to post on different Team channels. 

 

Snag_3ce991.png

 

The goal is to include the user who completed the Planner task into the message, but idealy I would want the user who completed the task to post a message by that user in Teams. For instanced if I completed a planner task post message by my user ID in teams that I completed a task. 

Anonymous
Not applicable

Hi @vecerpa

 

Thanks for the feedback. This makes sense, based on the research I did on all the variables available for Planner in MS Flow. I will be sure to add this to a feature request. 

 

I will try this method and see where it takes me. What would this look like? I would have to create multiple conditions, one for the Get request (don't see this function), another to Pull the user ID info?  

Hello, @Anonymous!

 

Thank You for posting in the Flow Community!

 

I see that you were offered some solutions to your Flow Issue! If you feel as though any of these replies were satisfactory, please click the "Accept as Solution" button so that other Flow users can find and utilze this information more easily.

 

Thank You!

-Gabriel

(Flow Community Admin)

- Gabriel
Community Manager
Power Automate | Power Virtual Agents
Super User Program Manager



Anonymous
Not applicable

After the Task Complete trigger, add an action to "Get User Profile" and pass it the Planner "Completed by ID" value. This will give you a bunch of options, including the User Profile's Display Name (populated, in this case).

 

Sadly, I still haven't found a way to either @ mention the person or make it appear that the person who completed the task is the one who posted the message. 

 

 

HonzaUH
Advocate I
Advocate I

Hi @Anonymous ,

I just found a solution to this today. There seems to be no other discussion on this matter anywhere, but this worked after some brainstorming.

1) add a Get user profile (V2) and Initialize variable parts right after the trigger part like so:

completed.PNG

 

 

 

 

 

 

 

 

 

 

2) then in the Get user profile part you put in this: triggerBody()?['completedBy']?['user']?['ID']

3) set value to Display name in the variable

Works like a charm. Cheers

kdavis91
Continued Contributor
Continued Contributor

@HonzaUH 

 

Here I am three week after your post and unable to use your solution. Based on the change in Planner icon, either MS changed something, or I'm using the wrong connector.

 

There is no Dynamic Content called "Completed by User" or any reasonable facsimile thereof and when I tried entering 

 

triggerBody()?['completedBy']?['user']?['ID']

 

as manual input, the flow failed at that step, and I received the below error:
Run Output.png

 

Am I missing something? Did MS change the Planner connector in the short time between your post and my attempt to apply your suggestion today?

 

Any help is greatly appreciated!

 

Kyle

 

Hi! @kdavis91

I believe the problem is you didn't input the command as an expression. You literary have to input it as an expression. Your input is just plain text without any functionality. I hope it makes it clearer.

 
 
kdavis91
Continued Contributor
Continued Contributor

Thank you, @HonzaUH 

 

My mistake betrays my newness to Power Automate, and the tangential nature of coding to my profession (accounting).

 

It briefly crossed my mind that it may have to be a function, but it was very brief.

 

To use your very true observation: it works like a charm!

 

Thanks, again!

 

If there is anyway for a Mod to select @HonzaUH's answer as the solution, it should be done!

@kdavis91 No shame there, Kyle. Me also being a newbie, it actually took me a few hours to find this solution. To escalate on the solution, it is actually just a way to access information hidden in the body of the trigger (you can find the contents of the body if you check the connector after a test run, the values are displayed there). The body should look something like this:

 
{
  "@odata.etag""W/\"JzEtVGFzayAgQEBAQEBAQEBAQEBAQEBAVCc=\"",
  "planId""wS_P8gQny0qYXBsULwgqW5YAH0-H",
  "bucketId""E_krDwE53UqCdFywpiCUvZYAMmu2",
  "title""Ověření kvality MP3 pro vyhlašování stanic",
  "orderHint""8586175816263579832P^",
  "assigneePriority""",
  "percentComplete"100,
  "startDateTime"null,
  "createdDateTime""2020-03-12T15:01:59.2445231Z",
  "dueDateTime""2020-03-31T10:00:00Z",
  "hasDescription"false,
  "previewType""automatic",
  "completedDateTime""2020-04-15T06:02:26.1513762Z",
  "referenceCount"0,
  "checklistItemCount"0,
  "activeChecklistItemCount"0,
  "conversationThreadId""AAQkADYyNWMzNDM4LWI2M2ItNGUxNC1hOGIxLTA0NTZjNWQzYzM2ZAMkABAAFv3BbrAYvEORn00UeWJ8-BAAFv3BbrAYvEORn00UeWJ8-A==",
  "id""ZiiL8zXJSUmIkWC37JJQ2JYAGn-s",
  "createdBy": {
    "user": {
      "displayName"null,
      "id""ff0aad75-3b19-496c-9e5c-bedbde8a8176"
    }
  },
  "completedBy": {
    "user": {
      "displayName"null,
      "id""c0d29a3e-af8c-4508-aa61-030e0f7b9821"
    }
  },
  "appliedCategories": {},
  "assignments": {
    "c0d29a3e-af8c-4508-aa61-030e0f7b9821": {
      "@odata.type""#microsoft.graph.plannerAssignment",
      "assignedDateTime""2020-03-12T15:01:59.2445231Z",
      "orderHint""8586175816263579832Pc",
      "assignedBy": {
        "user": {
          "displayName"null,
          "id""ff0aad75-3b19-496c-9e5c-bedbde8a8176"
        }
      }
    }
  },
  "_assignments": [
    {
      "userId""c0d29a3e-af8c-4508-aa61-030e0f7b9821",
      "value": {
        "@odata.type""#microsoft.graph.plannerAssignment",
        "assignedDateTime""2020-03-12T15:01:59.2445231Z",
        "orderHint""8586175816263579832Pc",
        "assignedBy": {
          "user": {
            "displayName"null,
            "id""ff0aad75-3b19-496c-9e5c-bedbde8a8176"
          }
        }
      }
    }
  ]
}
 
Which is a json object. So you see this expression triggerBody()?['completedBy']?['user']?['ID'] is only a way to access the correct value in the body object. It is quite useful to understand this, because most of the values that come in trigger and connector outputs aren't accessible through dynamic content. Through the syntax I used, you can access any value in any output you get in Flow. I hope this helps you in the future.

Good luck, Kyle!
kdavis91
Continued Contributor
Continued Contributor

@HonzaUH That is incredibly helpful and informative! I will remember (and surely use) that! thank you!

seanpcoa
Regular Visitor

Hi @HonzaUH , when I create the expression for the User/UPN field in Get user profile (V2) like so:

01.png

 

I don't end up with a green completedBy dynamic variable as shown in your screenshot:

02.png

 

Instead, I end up with this, and the flow errors out (404 not found):

03.png

Any ideas on what I might be doing wrong? Thanks!

kdavis91
Continued Contributor
Continued Contributor

@seanpcoa 

 

Make sure that the expression actually stayed in the text field...I have occasionally experienced the frustration of putting an expression into the field, hit "OK" and then open it back up to realize that it is only "triggerBody()" and not the full expression...

 

...not sure if this is your issue, but it's worth checking.

 

thanks,

Kyle

@kdavis91 thank you for that tip! I saved, exited the flow, then went back to edit the flow. The field is now green as shown in @HonzaUH 's screenshots. Not sure why I would need to leave, then come back. However, I cannot see the code in the expression to verify it's still there:

2020-07-16_13-23-10.png

 

 

kdavis91
Continued Contributor
Continued Contributor

Glad that it's working now!

 

Not sure why PA acts the way it does sometimes. Sometimes saving and leaving is what it takes! 😕

 

to see the expression, hover your cursor over the green box...

 

I think the reason it doesn't show up in the expression box is so that you can add another expression if you want to (though you'd think Microsoft could just add an option to add new or edit existing...).

 

to keep the expression in a place that you can readily see it and copy it if needed, you can add a comment to the action block (accessed in the options list at the top right of each action block) and type/paste the full expression there.

 

thanks,

Kyle

@Kevin <facepalm> I've been so used to clicking into the field to add the expression I didn't even bother to check the obvious. Thanks for pointing that out! I'm still back at the original problem: the flow fails at Get user profile (V2) with 404 resource not found in the Body output. Pretty frustrating, it seems I must be missing something obvious here. In this flow, I've kept it as simple as possible for testing, but can't seem to extract the completedBy user ID in the Get user profile (V2) step:

02.png

 

 

Adding a bit to this, when we use the expression triggerBody()?['createdBy']?['user']?['ID'] the flow works, and we get to the good bits in the user profile:

01.png

 

However, when we use the expression triggerBody()?['completedBy']?['user']?['ID'] the flow breaks and we get a 404 not found:

02.png

 

Both createdBy and completedBy contain valid user ID strings in the trigger body:

03.png

 

Any ideas or advice would be greatly appreciated!

Hi @seanpcoa !

If I am correct, you are using multiple triggers in your Flow. It is most likely that 'triggerBody()' only works for the first trigger in the whole Flow. So you are basically trying to find this value triggerBody()?['completedBy']?['user']?['ID'] in a bad triggerBody. Of course it isn't there (well it is, but the path is diferent and the value is NULL), so hence goes the error. I can't think of a solution to this now, because I am quite busy, but you can definitely make it work if you only use one trigger action per Flow 🙂

Cheers and GL!

View solution in original post

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

Users online (101,270)