cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Dominik2357
Regular Visitor

How to get user display name from unique ID

Hello everyone,

i know this might seem redundant but none o the solutione here work. 

This solution should be perfectly fine, but somehow it doesn't work: https://powerusers.microsoft.com/t5/General-Power-Automate/how-to-get-name-of-user-task-assigned-to/...

 

I need an email with a username for each user leaving a team. This is what I built:

 

Dominik2357_0-1634117430455.png

 

and I'm getting this error:

 

Dominik2357_1-1634117459772.png

 

Nothing seems to work. I tried initializing a variable and saving the DIsplayName in it - no luck. 

 

Any suggestions? Thank you!

Dominik

2 ACCEPTED SOLUTIONS

Accepted Solutions
eric-cheng
Solution Sage
Solution Sage

Hi @Dominik2357 ,

 

Can you try removing the loop?  Because there is only ever 1 record, you wont' need it.

 

ericcheng_0-1634119135577.png

 

--------------------------------------------------------------------------
If I have answered your question, please mark my post as a solution
If you have found my response helpful, please give it a thumbs up

Connect on LinkedIn

 

View solution in original post

CFernandes
Super User
Super User

Hey @Dominik2357 

 

The problem is with the loop - Userid returns a GUID however the loop is need an array.

 

CFernandes_0-1634121405087.png

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

 

P.S. take a look at my blog here and like & subscribe to my YouTube Channel thanks.

 

 

View solution in original post

4 REPLIES 4
eric-cheng
Solution Sage
Solution Sage

Hi @Dominik2357 ,

 

Can you try removing the loop?  Because there is only ever 1 record, you wont' need it.

 

ericcheng_0-1634119135577.png

 

--------------------------------------------------------------------------
If I have answered your question, please mark my post as a solution
If you have found my response helpful, please give it a thumbs up

Connect on LinkedIn

 

View solution in original post

CFernandes
Super User
Super User

Hey @Dominik2357 

 

The problem is with the loop - Userid returns a GUID however the loop is need an array.

 

CFernandes_0-1634121405087.png

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

 

P.S. take a look at my blog here and like & subscribe to my YouTube Channel thanks.

 

 

View solution in original post

Dominik2357
Regular Visitor

So don't ask me why, but as long as I work with the German UI, the step get user profile (V2) automatically creates this loop. There is just no way to get rid of it - that's why I thought it's mandatory. 🤔

After I switched to EN (for the screenshots) everything works fine. 

THANK YOU!

Hey @Dominik2357 - I just glad that our inputs helped you resolve your problem. 😊

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Users online (3,522)