cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
gautmish
Helper III
Helper III

Include user photo in the mail body in microsoft flow

Hi

I would like to include the photo of the  user in "To" of the email in the mail body . Is there a way i can include the image . I can put the image in sharepoint and access it from there . Please let me know the way to do so .

 

Thanks

Gautmish

5 REPLIES 5
manuelstgomes
Super User
Super User

Please check the following flow to see if it works for you...

small-Screenshot_2019-08-21_at_19_22_16.jpg

It's quite simple:

  1. Since you're saving it in SharePoint you only need to get the file's URL and send it in the email
  2. You can pick a Thumbnail (small, medium or large) or the actual file (Link to Item) by replacing in the src=part.
  3. In this case, I uploaded a random image and fetched its information by ID but you can embed this logic in your current flow as long as you have an image.

Regarding the DIV, this is the only way I got it to show up on Outlook. Sending images is quite tricky but the suggestion came from another post that you can find here

 

Please let me know if this works for you and don't forget to mark the question as "accepted" to allow for others to find the solution faster.

@gautmish 

Hey there.  If you're using Office 365, there's actually an action with the Office 365 Users connector, "Get User Photo".

 

You could probably just insert that step and then use @manuelstgomes method for inserting in the html email.

 

Just a thought.

-Ed-

 

 

If this reply has answered your question or resolved your challenge, please consider marking it as a Solution. This helps other users find it more easily via search.

@edgonzales has a point. Actually, I considered that when writing the post but since @gautmish also mentioned that he could store the information in SharePoint I decided for this approach so that he can send with any image.

@manuelstgomes  Hi 

 

I tried the same , it is working only if i am setting the "File path" by selecting from sharepoint path but if I am passing it dynamically it is showing file not found or removed .

 

any idea??

 

Thanks

Gautmish

@gautmish sorry for taking so much time to reply. Let's try to figure this out :).

 

I think I had the same issue in the past. If you pass the value dynamically, then you'll have a string, so you need to encode it. Try the following. Run the flow with the dynamic content and see the content being generated. There are spaces and other characters there, right?

If you copy that URL to the browser, it will probably fail or convert the value for you automatically.

A simple replace will do the trick:

replace(<YOUR VALUE>,' ','%20')

Double-check again and if you see any special character grab the whole URL and copy it here:

https://www.url-encode-decode.com

Then you know that you have to replace character X with "%...".

 

If it doesn't work let me know where it's failing and I'll try to help you. 

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Cheers
Manuel

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Users online (3,516)