cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
monstrator
Frequent Visitor

Including wide tables in approval mail

Hi experts!

 

I managed to get additional approval-related information into the approval email sent from my flow. The problem I have is that the table is very wide. That in combination with the approval mail having fixed width causes the information in the table to look like this:

 

monstrator_0-1619504873028.png

 When I forward the email the fixed width is getting removed and the table looks OK:

 

monstrator_1-1619504940122.png

Also in MS Teams the table looks good:

 

monstrator_2-1619504987877.png

 

Any idea how to change the approval mail available width?

 

Thanks and have a nice day everyone!

 

Regards, Denis

1 ACCEPTED SOLUTION

Accepted Solutions

I figured out a way of solving this by using 'Send email with Options'. Simply add options 'Approve' and 'reject' and evaluate the answer afterwards. This of course only works via mail and cannot be used inside Teams or in Dataverse when the user is logged in. But still, it solved the issue for me 🙂

 

monstrator_0-1620219593913.png

 

BR, Denis

View solution in original post

5 REPLIES 5
jinivthakkar
Resident Rockstar
Resident Rockstar

@monstrator click on code view on email action 

 

jinivthakkar_0-1619591577970.png

and then paste the html 

jinivthakkar_1-1619591649452.png

I tried this html : https://www.w3schools.com/cssref/tryit.asp?filename=trycss_table_table-layout

 

it has 4 table designs, I think you will be interested in below highlighted designs:

jinivthakkar_2-1619591789666.png

Basically you will have to include css and html to get the desired output.

 

--------------------------------------------------------------------------------
If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.

 

 

monstrator
Frequent Visitor

Hi @jinivthakkar ,

 

thanks for your post but this is not my problem. I am using the "start and wait for approval" step for which you cannot use HTML in the body:

 

monstrator_0-1619596060746.png

 

You can only use markdown language and the frame for the approval mail body seems to be fixed width.

 

BR, Denis

jinivthakkar
Resident Rockstar
Resident Rockstar

@monstrator I tried below different combinations of html and css but nothing seems to be working, so I conclude that it can't be done. There is nothing on the official documentation here - https://docs.microsoft.com/en-us/power-automate/approvals-markdown-support#tables

 

<div class="foo">

Header | header
------ | -----
Bar | bar

</div>
<style>


.foo table {
border-collapse: collapse;
  border: 1px solid black;
}
</style>
| <div style="width:290px">property</div> | description                           |
| --------------------------------------- | ------------------------------------- |
| `border-bottom-right-radius`            | Defines the shape of the bottom-right |
<style>
table th:first-of-type {
    width: 10%;
}
table th:nth-of-type(2) {
    width: 10%;
}
table th:nth-of-type(3) {
    width: 50%;
}
table th:nth-of-type(4) {
    width: 30%;
}
</style>


+---------+---------+---------+----------+
| Header1 | header2 | header3 | header4  |
+---------+---------+---------+----------+
| Bar     | bar     | bar     | bar      |
+---------+---------+---------+----------+

 

--------------------------------------------------------------------------------
If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.

monstrator
Frequent Visitor

@jinivthakkar Yes, I think that's how it his. Thanks for checking! I will create an SR to see if anything could be done.

 

BR, Denis

I figured out a way of solving this by using 'Send email with Options'. Simply add options 'Approve' and 'reject' and evaluate the answer afterwards. This of course only works via mail and cannot be used inside Teams or in Dataverse when the user is logged in. But still, it solved the issue for me 🙂

 

monstrator_0-1620219593913.png

 

BR, Denis

View solution in original post

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Users online (14,708)