cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Frequent Visitor

Invalid Template Error in flow

Hi,

 

My flows are giving below error:

"InvalidTemplate. Unable to process template language expressions in action 'Delete_item' inputs at line '1' and column '2128': 'The template language expression 'json(decodeBase64(triggerOutputs().headers['X-MS-APIM-Tokens']))['$connections']['shared_sharepointonline_1']['connectionId']' cannot be evaluated because property 'shared_sharepointonline_1' doesn't exist, available properties are 'shared_sharepointonline'. Please see https://aka.ms/logicexpressions for usage details.'."

 

I know the workaround that export flow and import again and reattach it to power apps. then it will work fine. But this is not the proper solution.

 

suddenly the app is in live flows are failing with this error. which will impact the users activities. Need perminant solution for this.

 

Regards

Bhavani K

 

8 REPLIES 8
Community Support
Community Support

Hi @kb2447,

 

Could you please share your Flow configuration?

Where did the issue happen in the Flow actions?

If you can give more detail about your situation, we can assist you better.

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Below is the one of the flow configuration. the same thing is happening in other flows too. Deleting flow after exporting and importing it & retagging it to power apps is resolving the issue. But this is not the correct way. If the app will go on live and this intermittent issue will cause lot of problems.
Flow configuration.png

 

Hi @kb2447,

 

How about having a test that using the Send an Http request to delete the item? You can refer below:

Capture.PNG

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi, 

This is not about the action which i used there. i am getting such error in other flows in various actions. below is the old screen shot. this error also gone after exporting and importing as new flow.this occured at SQL action.error at sql action.png

 

Hi @kb2447,

 

The error that you have shared occurs when you have added an action to the flow after adding the flow to the PowerApps control. What you have to do now is, go to the PowerApps and from the control, copy the expression that you are using to trigger the flow and then remove the flow from there and re-register it. Now you should be able to run the flow just fine.

 

Note that whenever you add an action to flow after adding it to a PowerApps control, you have to remove it from there and re-register it for it work properly.

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi,

 

yeah we used to follow the solution which you mentioned when ever we add new action in flow. But the flow configuration which i provided was done 2 months back and attached to a control in the power app. 

 

A user which used it on yesterday reported that items are not deleting. then when i open the flow and its got failed resulting the error.

 

Please provide permenant solution.

 

thanks

I know this was a while ago but I've been having the same issue lately, did you ever figure out a fix?
The only think I find fixes this saving a copy of the flow and updating the flow name in powerapps.

didnt get fixed solution for this error. 
As you mentioned, we need to save the flow copy and update the new copy name in powerapps, will be the workaround till now.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Users online (7,858)