cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ARoseWilliamson
New Member

Launch New Browser Action will not connect to the browser

Power Automate Desktop was updated last week and since then the Launch New "Browser" action has not been able to connect to the chosen browser. This is the error message I am getting: "Failed to assume control of Microsoft Edge (Communication with browser failed. Try reloading extension)."

 

Error Details: "Exception of type 'Microsoft.Flow.RPA.Desktop.UIAutomation.WebAutomation.Core.Browser.WebBrowserException' was thrown.: Microsoft.Flow.RPA.Desktop.Robin.SDK.ActionException: Failed to assume control of Microsoft Edge (Communication with browser failed. Try reloading extension). ---> Microsoft.Flow.RPA.Desktop.UIAutomation.WebAutomation.Core.Browser.WebBrowserException: Exception of type 'Microsoft.Flow.RPA.Desktop.UIAutomation.WebAutomation.Core.Browser.WebBrowserException' was thrown.
at Microsoft.Flow.RPA.Desktop.UIAutomation.WebAutomation.Core.WebExtensionsBrowser.WebExtensionsBrowserLauncher.LaunchNew(ProcessWindowStyle processWindowStyle, String initialUrl, Int32 timeout)
at Microsoft.Flow.RPA.Desktop.UIAutomation.Plugin.Edge.Edge.StartNew(ProcessWindowStyle processWindowStyle, String initialUrl, Int32 timeout)
at Microsoft.Flow.RPA.Desktop.Modules.WebAutomation.Actions.WebAutomationActions.LaunchNewEdge(Variant initialUrl, Variant edgeTabTitle, Variant edgeTabUrl, Variant dialogButtonToPress, Variant& webBrowserInstance, Int32 operation, Int32 windowState, Int32 attachMode, Boolean waitForWebPageToLoad, Int32 courseOfActionIfDialogAppears, Boolean clearCache, Boolean clearCookies, Int32 timeout)
at Microsoft.Flow.RPA.Desktop.Modules.WebAutomation.Actions.LaunchEdgeBase.Execute(ActionContext context)
--- End of inner exception stack trace ---
at Microsoft.Flow.RPA.Desktop.Modules.WebAutomation.Actions.LaunchEdgeBase.Execute(ActionContext context)
at Microsoft.Flow.RPA.Desktop.Robin.Engine.Execution.ActionRunner.Run(IActionStatement statement, Dictionary`2 inputArguments, Dictionary`2 outputArguments)"

 

I have tried a variety of ways to fix this (such as redownloading the Extention) and have come up with nothing.

1 ACCEPTED SOLUTION

Accepted Solutions

I had to switch browsers from Microsoft Edge.

View solution in original post

3 REPLIES 3
aontanon
Helper I
Helper I

Hello

I have had the same problem with Microsoft Edge since I updated PAD to the last version (2.15)

I tried enabling/disabling the extension, rebooting the computer, reinstalling Microsoft Edge, but still is not working ...

I have another computer with the same PAD version and it is working fine, so I don't understand

Did you find any solution?

Thanks!

 

ARoseWilliamson
New Member

Not yet.

I had to switch browsers from Microsoft Edge.

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Power Automate Designer Feedback_carousel.jpg

Help make Flow Design easier

Are you new to designing flows? What is your biggest struggle with Power Automate Designer? Help us make it more user friendly!

Users online (3,007)