cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
SamPo
Level 10

Location Based Flow Not Working

Hi All,

 

I'm trying to build a location based flow using the new 'when I enter or exit an area' trigger but can't seem to get it to work.

I've set the geofence to be 200m from my office and I've since come in and out of work 3 times but the flow has failed to run.

The flow ran a couple of times successfully straight after I created it (from my office) but since then, nothing.

 

Anyone have any ideas?

 

Tagging here @J_Karlsson @jdrussell78 @yoshihirok @Expiscornovus as I have seen posts from each of you that seemingly have it working.

 

Thanks!

 

Sam

1 ACCEPTED SOLUTION

Accepted Solutions
SamPo
Level 10

Re: Location Based Flow Not Working

Confirmed definitely now working! Seems like reinstalling the app did the trick.

 

Thanks to both of you!

View solution in original post

17 REPLIES 17
jdrussell78
Level: Powered On

Re: Location Based Flow Not Working

Do you have the flow app installed on your phone with location services set to always with the app ?

Thats the step I missed and since then it works like a dream.

More details on my blog post here -

https://www.jondoesflow.com/post/when-i-enter-or-exit-and-area

SamPo
Level 10

Re: Location Based Flow Not Working

@jdrussell78 Hi Jon,

 

It seems like my permissions are set up correctly, I can even see the location service pinging the flow app here:

af338536-20cf-4d81-aab3-5adaf49f09d1.jfif

 

Not sure where to set it to 'always'. Under the app settings it just shows location as 'on' (I'm on android).

39a46444-744b-4be5-b9bf-564f82f92ef3.jfif

I've also checked that its not being restricted by any battery saver settings or something like that.

 

Any other ideas?

 

Thanks

Sam

Super User
Super User

Re: Location Based Flow Not Working

Hey @SamPo 

 

 

Are you logged in to the mobile app with the right credentials or the credentials which uses the location trigger.

 

 

Kind regards

 

 

Tom





Did I answer your question? Mark my post as a solution!

Proud to be a Flownaut!





jdrussell78
Level: Powered On

Re: Location Based Flow Not Working

Yes, I was logged in as the correct tenant.

SamPo
Level 10

Re: Location Based Flow Not Working

@Tom_Slosse Hey Tom,

 

Yes, I'm logged in to the same account and environment (I only have 1 environment and one tenant from my account) both from the web and on the app. I see the location flow in the flow mobile app with its history so I know there's definitely no issue at the account level. 

As you see above I've set all the location settings I can find but still no luck.

As I mentioned above the flow did run once after I saved it and the long/lat from that flow was correct to the location of my phone at that time but is simply not triggered when I enter or exit the area.

 

Thanks! 

Super User
Super User

Re: Location Based Flow Not Working

Hey @SamPo 

 

 

Mhm that is indeed weird. Were there any changes in that Flow after it ran succesfully until now?

You didn't Turn Off the Flow or anything?

 

Kind regards

 

 

Tom





Did I answer your question? Mark my post as a solution!

Proud to be a Flownaut!





SamPo
Level 10

Re: Location Based Flow Not Working

@Tom_Slosse Nope, I created the flow yesterday just before I left the office hoping that when I went home it would cause it to run but didn't make any changes to it since it ran successfully that first time.

I'll try copying it to a new flow and I'll share it with some of my team members as well to see what happens.

Very annoying that there's no way to test these location flows without physically moving. I think I'll install a GPS spoofer on my phone which can hopefully replicate the movement.

 

Don't know if its relevant but I get this error when trying to run manually: Flow 'XXX-XXX' cannot be installed.

Super User
Super User

Re: Location Based Flow Not Working

Hey @SamPo 

 

 

Would like to hear if you got it working again.

It is indeed frustrating when you don't get a proper view on that trigger and when everything is ran in the background and throws an error or doesn't even do it's magic.

 

Keep us posted 🙂

 

Kind regards

 

 

Tom





Did I answer your question? Mark my post as a solution!

Proud to be a Flownaut!





jdrussell78
Level: Powered On

Re: Location Based Flow Not Working

What happens when you try and test using the successful previous test?

SamPo
Level 10

Re: Location Based Flow Not Working

@jdrussell78 When I use the previous run as a test, it all works as expected. The flow itself works well, only the trigger seems to be an issue

jdrussell78
Level: Powered On

Re: Location Based Flow Not Working

have you recreated the flow ?

SamPo
Level 10

Re: Location Based Flow Not Working

@jdrussell78 @Tom_Slosse I recreated the flow and reinstalled the app on my phone and looks like it now worked. I got a timestamp for exactly when I left the office. I want to wait until tomorrow and see that I get another ping when I arrive in the morning to know that its definitely all working properly.

 

Thanks for all your help.

 

Sam

jdrussell78
Level: Powered On

Re: Location Based Flow Not Working

Good news Sam. Feel free to mark my comment as solved 😉
SamPo
Level 10

Re: Location Based Flow Not Working

Confirmed definitely now working! Seems like reinstalling the app did the trick.

 

Thanks to both of you!

View solution in original post

Super User
Super User

Re: Location Based Flow Not Working

Hey @SamPo 

 

 

No problem at all.

Glad you find the solution for this!

 

Kind regards

 

Tom





Did I answer your question? Mark my post as a solution!

Proud to be a Flownaut!





Highlighted
Eliot
Level: Powered On

Re: Location Based Flow Not Working

Going to ask the stupidest question of the decade ... Will this work with Flow for Windows Mobile? (on mi' good old lumia testing phone)

 

Eliot
Level: Powered On

Re: Location Based Flow Not Working

yeaaahhhhhh ... I'm still getting this issue 😓

 

on android ... and on win phone.

 

the "cannot be installed" error being the PITA ... 😫

 

i'll link to a new thread in a second.

 

EDIT - Come be my friend if you find this ... https://powerusers.microsoft.com/t5/Using-Flows/Location-Trigger-Still-Failing-With-quot-cannot-be-i...

Helpful resources

Announcements
firstImage

Power Platform Online Conference

Speakers, submit your sessions now! Call for speakers ends Feb. 10!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors (Last 30 Days)
Users online (3,519)