cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper I
Helper I

MS Approval flow goes in infinite waiting state.

We have Power-app connected MS flow for multiple level approval process,

Flow URL: https://us.flow.microsoft.com/manage/environments/Default-bcdadde4-9fc2-4200-9d1d-c1efe1c77b43/flows...

Approval process was working fine until we attached PDF to Approval email.

We are using "Convert HTML file to PDF connector" for attachment of file to email as explained by Shane Young in his video
https://www.youtube.com/watch?v=2rfAQe1kK8M

But after this "Start and Wait for Approval" goes in infinite waiting state.

It would be great if PowerApps team look into this and let us know whats the issue.flow error 2.png

 

Thanks in Advance.

2 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted

 

Hi @SudhirSingare ,

 

This problem has been transferred to a dedicated team to solve, if there are any updates, I will promptly feedback.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Highlighted

 

Hi @SudhirSingare ,

 

I did a test on my side and found that the problem has been solved, please take a try again.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

16 REPLIES 16
Highlighted
Memorable Member
Memorable Member

Hey @SudhirSingare 

 

 

Has the approval being approved at this time?

Because the action Wait for approval waits until it got a response from the approver.

Can you show us a screenshot of how you set up your Create an approval step?

 

Kind regards

 

Tom



If this reply has answered your question or solved your issue, please mark this question as answered.

Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up.

Highlighted
Dual Super User III
Dual Super User III

How many approvers does the approval go to?  And are you saying that when all the approvers have responded to their email that the flow never progresses?  Otherwise its normal for the flow to pause at this point until all approvers have clicked either the approve or reject button in the approval email.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.
Highlighted

It suppose to go to 5 levels one after another. But it stucks in First step as After first Approver Approves req from Email it's in continuous wating state.

Very strange: no errors or details available.
Highlighted

In your Create Approval step are you using the first one to approve Approval Type? Also, how many approver emails are you adding to the Create Approval step?  If you want 5 separate approvals then you need 5 separate actions.  Otherwise it will wait until all 5 have approved before it moves on.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.
Highlighted

Hey @SudhirSingare 

 

 

Is your Approval set up for everyone needs to approve or only the first responder?

Because if you choose the first option you will have to wait until everyone has approved the request to go to the next step.

 

Kind regards

 

Tom



If this reply has answered your question or solved your issue, please mark this question as answered.

Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up.

Highlighted

Hey

 

 

Did my post just disappear?

 

Kind regards

 

 

Tom



If this reply has answered your question or solved your issue, please mark this question as answered.

Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up.

Highlighted

Hey @SudhirSingare 

 

 

 

Could you share a screenshot of your Create an approval step?

 

Kind regards

 

Tom



If this reply has answered your question or solved your issue, please mark this question as answered.

Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up.

Highlighted
Helper I
Helper I

Yes. I have 5 different Approval Actions. These actions are conditional. Means flow is configured in such way that only Sequential approval will happen example: If Local FM approves then only it goes to regional manager.

Here you see in image is condition for Local FM only.

Also this was working fine until I added of form - > html - > PDF as attachment, But all PDF related action are green (see attachmentattachment

This sounds weird but Approver gets pdf in email, he checks pdf and happily Approves Req, but nothings happening after that.

🙂
Highlighted

No image attached.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.
Highlighted

In the main post.
Highlighted

Sir, After 6-7 hours after Approving its approving them now in flow

Now I don't know how to figure out what caused this, can u suggest some steps.
Highlighted

 

Hi @SudhirSingare ,

 

Do you mean that after adding attachments in the approval action, even if approver has completed the approval, the flow is always running?

If so, we have confirmed that this is a known issue and we have reported it.

Please check this similar thread:

https://powerusers.microsoft.com/t5/Using-Flows/Approval-given-by-approver-but-sits-in-pending-upto-...

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted

@v-bacao-msft  Exactly! Same thing happening. 

Because there is nothing no errors.

Thank you for response, can i see any link where issue is reported?
Or how can know if its resolved ?

Highlighted

 

Hi @SudhirSingare ,

 

This problem has been transferred to a dedicated team to solve, if there are any updates, I will promptly feedback.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Highlighted

 

Hi @SudhirSingare ,

 

I did a test on my side and found that the problem has been solved, please take a try again.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Highlighted

Yes. It works fine now.

Thank you. 🙂

I think we can close this thread.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Users online (10,951)