cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
maxb57
Regular Visitor

MS Flow looking for deleted SP columns

I deleted two columns out of a Sharepoint list, and now Flow errors out when it tries to access an SP item out of that list. The error message indicates that Flow does not know the columns have been deleted. Any thoughts? Is there something that I can do to "refresh" Flow to get rid of references to the old deleted columns?

1 ACCEPTED SOLUTION

Accepted Solutions
v-yuazh-msft
Community Support
Community Support

Hi @ maxb57,

 

Could please share a screenshots of the configuration of your flow?

 

I have made a test on my side and the issue is confirmed on my side. If you have deleted some columns of a Sharepoint list, and the flow would run failed when access to the deleted columns of the list. Because the flow couldn’t find the deleted columns.

 

The only way to do this is to delete the action that references the deleted column and add the action again.

 

 

Regards,
Alice Zhang

View solution in original post

13 REPLIES 13
PhilD
Kudo Kingpin
Kudo Kingpin

Same experience here...

 

"status"400,
  "message""The passed-in field \"Mid_x002d_Year\" could not be found\r

 

Column "Mid Year" was deleted yesterday.

 

I deleted the SharePoint connection to the Flow and recreated it but that didn't seem to help.

v-yuazh-msft
Community Support
Community Support

Hi @ maxb57,

 

Could please share a screenshots of the configuration of your flow?

 

I have made a test on my side and the issue is confirmed on my side. If you have deleted some columns of a Sharepoint list, and the flow would run failed when access to the deleted columns of the list. Because the flow couldn’t find the deleted columns.

 

The only way to do this is to delete the action that references the deleted column and add the action again.

 

 

Regards,
Alice Zhang

View solution in original post

Any update regarding this. Dont know why its refering the deleted column

For my part, I deleted the action that referred to the deleted column and rebuilt that action from scratch.

 

This solved the problem but the apparent fragility of all of this is not very confidence inspiring to say the least...

Agreed, this level of fragility is really scary. If someone renames a column or deletes a column, Flow should automatically update to match, not break so badly that you have to rebuild the thing from scratch.

FYI, the Flow checks the FieldName of the column not the DisplayName. When you rename a column you only change the DisplayName, so it won't break the Flow.

@JPvdB that is true, only deleting a column entirely causes the issued described here (where Flow continues to look for a now nonexistent column). Renaming a column does not seem to cause any problems.

Anonymous
Not applicable

Does anyone know if this is raised as an issue at Microsoft?

 

For now I will re-create the whole action but it is way cumbersome taking the fact I was working on those actions half a day, as they are quite long and complex...

Definitley needs to be fixed. Can this be enterd as a bug somewhere?

TonyHignett
New Member

Any update on this?

re-creating the action from scratch surely cannot be the only answer!

There should be an option on Microsoft Flow "Create item" action part something like "Refresh" which will prompt for update automatically column names as per list column OR small hyperlink option called "Delete" same as like "Add dynamic Content" underneath of the column name.

I know that this is a fairly old thread - but did any of you find a solution for this?

I have the same mess with multiple Flows due to, what looks to be, a very common issue.

Also, it says that this thread has a solution, but I can't seem to find it in any of the replies? What's marked as a reply is "The only way to do this is to delete the action that references the deleted column and add the action again.", but that definitely isn't a solution - it's a hack at best.

Thanks.

Hi,

 

You need to update one 'update item' template and then rest templates will update automatically. I have tested this issue and found that if Items are existing in SharePoint list and update item template fetch latest data from SharePoint list. if you delete all previous item and then update any one template in your flow, this issue will resolve.  

You can verify this by creating one calendar event though MS flow and then you will find Event id in calendar Id in create event. There is possibility that templates are not refreshing data properly while fetch all connections.

 

Thanks

Hardesh

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Users online (27,026)