cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
LOlofsson
New Member

MS Forms Form ID + Power Automate Flow

Hi there,

I have created an MS Form which I've set up in Power Automate to send email notifications to multiple individuals when a new MS Form response is submitted. I can't find the form in the Power Automate Flow drop down menu, so I had to manually enter the ID.

However, I couldn't find the Form ID in my MS Form neither in the edit view or share view URL.... so I have tried using the Design ID or session ID... these don't work.  Can someone help me to suggest how I can find my Form ID so I can manually add the form to the Flow, or, suggest how I can find the form in the drop down menu?  Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions

@LOlofsson you need to individually reference the answers from your form in the email. Use intellisense (dynamic content) to help you with that. It will have the title of each of your questions on the form.

If you found this response useful, give it a thumbs up and don’t forget to mark your post answered to help others find the solution easier.

View solution in original post

5 REPLIES 5
jatcube
Solution Supplier
Solution Supplier

@LOlofsson you can find the ID you need by

  1. navigating to https://forms.office.com/ then
  2. select your form
  3. Look for the 'https://forms.office.com/Pages/ResponsePage.aspx?id=' either in the address bar or click on collect response button and copy the long link. all the characters after the 'id=' is your form id that you can simply copy and paste into the connector.

 

If you found this response useful, give it a thumbs up and don’t forget to mark your post answered to help others find the solution easier.

LOlofsson
New Member

Thanks @jatcube !  I had copied the URL (viewing as user would view it) everything after the ResponsePage.aspx?id=.  However, the Power Automate Flow still doesn't work - it is not picking up the form when I enter it manually....

 

MS Forms Power Automate.jpg

 

It looks like it works ie. the status is marked as Succeeded when I test out the form and flow, but it the individual I am sending the tests to only receives the email, and not the MS Forms response... So, it still doesn't work - any other tips?  Could this be due to the fact that I had shared the MS Form with a group?

Blurryface
Resolver I
Resolver I

Hi @jatcube, if you can recreate the flow using the Power Automate template “Record form responses in SharePoint” - this should work with adding the Form ID as you’ve done so above. Let me know if this helps resolve your issue - thanks LT

LOlofsson
New Member

Thanks for your response!  I don't think I can do this because the individuals who I want the form emailed to (once a response is submitted) are not part of the same group/team that I am, so they wouldn't have access to our SharePoint site.  Ideally, I'd like the responses shared via email to all individuals....

@LOlofsson you need to individually reference the answers from your form in the email. Use intellisense (dynamic content) to help you with that. It will have the title of each of your questions on the form.

If you found this response useful, give it a thumbs up and don’t forget to mark your post answered to help others find the solution easier.

Helpful resources

Announcements
Power Automate News & Announcements

Power Automate News & Announcements

Keep up to date with current events and community announcements in the Power Automate community.

Power Automate Community Blog

Power Automate Community Blog

Check out the latest Community Blog from the community!

Users online (7,326)