cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Westex
New Member

Message id failure when trying to forward an email in flow

Hi, I am very new to flow (like a couple of days) and I am trying to set up a flow that does the following:

 

 When I receive any email in a designated folder in my Outlook (folder is called "Test_Flow", I want flow to forward that email to a designated recipient. 

 

It seems simple enough but I am getting a Message ID failure. More specifically it is saying that "Message ID if malformed" and giving me a 400 error code. I am attaching screenshots of my flow. Can someone help me out?

 

Thanks!

 

 

4 REPLIES 4
v-yamao-msft
Community Support
Community Support

Hi @Westex,

 

I assume that you have already created rules for your Outlook so that the email can be directed to the folder “Test_Flow”.


According to your description, I created a flow to test this issue. Before this, rules was created for my Outlook so that emails can be sent to the folder “Test_Flow”.


The flow was configured likes below.


In the action “Forward an email”, you need to select the dynamic content “Message Id” for Message id field. What have you selected for this field?

3.PNG

It worked fine on my side when an email arrived in Test_Flow folder.

4.PNG


Hope this could be a reference for you.

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi @Westex,

 

Welcome to Flow! Glad you are able to find the Flow Forums as a support resource as you build your Flow skills.

 

Have you had a chance to apply @v-yamao-msft's recommendation to adapt your Flow?

 

If yes and you found that solution to be satisfactory, please go ahead and mark this thread as "Solved". 🙂

 

Happy Flowing!

-AT (Community Admin)

Thank you, @v-yamao-msft !

That works for me, as I had no Idea where to get that mandatory message ID . )

Anonymous
Not applicable

Hi! I'm pretty new to flow too and am facing the same issue. However, I'm unable to find 'Message ID' in dynamic content. I've tried to manually get the message ID but it shows the same error too. I'm trying to forward the email from 'Get response details'.

 

Screenshot 2020-03-17 at 10.00.41 AM.jpgScreenshot 2020-03-17 at 10.19.25 AM.jpg

 

Thanks in advance!

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

Users online (46,945)