cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Andy-TFE
Regular Visitor

Moving an mail from a shared mailbox gives erros but does the job?

when i move an mail from a shared mailbox to an other mailbox flow gives an error but the mail is moved correctly

14 REPLIES 14
ScottShearer
Super User
Super User

@Andy-TFE:

 

Can you post screen shots of both your Flow and the error.  This will be a big help in trying to assist you.

 

Scott

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott
v-yamao-msft
Community Support
Community Support

Hi @Andy-TFE,

 

Are you trying to move email to some other mailbox when an email arrives in a Shared mailbox?

Please share a screenshot of your flow so that we could help figure out the issue.

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Andy-TFE
Regular Visitor

Hi,

That’s correct I run flow under an account named cloudservice@tfe.be and have a trigger when an email arrives in a shared mailbox named backupstatus@tfe.be. I move the mail from the mailbox of backupservice to cloudservice. The mail is moved but displays an error.

 

SnapFlow.jpg

Complete error message

 

{
"status": 404,
"message": "The specified object was not found in the store., The process failed to get the correct properties.\r\nclientRequestId: f0da4dca-a1cc-4cb9-8ea0-b73c099cb08c\r\nserviceRequestId: 4bc4371a-3e39-4a20-ba92-71192c1f68ff",
"source": "office365-ne.azconn-ne.p.azurewebsites.net"
}

This is pretty annoying because al flows run as thy should but the status is failed

DavidH1
Frequent Visitor

I seconded this. Super annoying to see a failure being reported although the emails were moved successfully.
M4ikez
New Member

Hey Guys, 

I have exactly the same issue. Flow seems to work fine, however Flow run - failed.

Is there any update on this?

 

Michał

I have the exact same issue. I have found two threads on the forum, however there is no one that have a solution. I have a "Move Mail (V2)" action that moves an email from my inbox to a subfolder in another mailbox. The email is actually moved as it should, however the flow still fails with the same error:

 

{
  "status"404,
  "message""The specified object was not found in the store., The process failed to get the correct properties.\r\nclientRequestId: 75e36a24-0ef3-4c0e-972a-2dce4cc0c654\r\nserviceRequestId: 370315ec-1a65-473e-b1a3-d7dba1e66b09",
  "error": {
    "message""The specified object was not found in the store., The process failed to get the correct properties.",
    "code""ErrorItemNotFound",
    "originalMessage""The specified object was not found in the store., The process failed to get the correct properties."
  },
  "source""office365-we.azconn-we-01.p.azurewebsites.net"
}

 

Furtermote I have noticed that the flow takes long time (approx one minut) before the mail is actually moved to the shared mailbox

TomDenoo
Regular Visitor

Any news on this? Still hitting this error when moving a mail from a user mailbox folder to a shared mailbox folder. Mail is moved correctly but action is throwing this 404 ("The specified object was not found in the store., The process failed to get the correct properties.") I'm using the azure AD HTTP request action.

VictorIvanidze
Resident Rockstar
Resident Rockstar

@Andy-TFE, configure "Run after" as shown here. 



Freelance Power Automate developer. $50 per hour.
haggren
New Member

Hi TomDenoo, Not much is new - I ran a support ticket with MS for over 6 months and nothing real came out of it other than a loose conclusion that the functionally was not really supposed to work this way and that they didn't really understand why it worked at all, and that they wanted to update the documentation to be clear about what the functionality was supposed to do instead which never happened (to me knowledge).

/haggren

Hats off to you Victor! It ain't pretty, but it gets the job done. Thx.

Hi @TomDenoo , thanks for your kind words. Don't you think you could mark it as a solution?



Freelance Power Automate developer. $50 per hour.

Helpful resources

Announcements
Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

User Group Leader Meeting January 768x460.png

Calling all User Group Leaders!

Don't miss the User Group Leader meetings on January, 24th & 25th, 2022.

Users online (1,261)