cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Multi-Select Option Set CDS in Power Automate - Not Available

Hi experts,

I have built an entity in the Common Data Service that has a multi-select option set as a field.  I am using Power Automate to build a flow that will want to check if a value is selected in the set of values.

level_of_complexity.PNGprocess_step_entity.PNG

 

I get the entity in the flow and based on a number of blog posts I was trying to add a "Compose" step where I was going to set it to the value of the field on my custom CDS Process Step entity.  The problem is all other fields show up on the entity except for the multi-select option set field.  It is just not in the list of dynamic content fields to choose from.  Am I missing something here?  

compose_step.PNG

I even tried to add a step right after the "Get" of the record for an "Update" to see if the field is available there to update and it is not listed in the fields for the entity, see below.

process_step.PNG

Thanks in advance for your assistance.  I did publish all customizations of course and already using this field on forms and data populated.

 

Thanks,

 

Drew

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Solution Supplier
Solution Supplier

Re: Multi-Select Option Set CDS in Power Automate - Not Available

Hi @dpoggemann 

Please try using the Common Data Services current connector instead of the Common Data Service. 

 

To use the CDS current connector your flow must be created from inside a solution. 

 

I have made a trial on the same and i could get the value using CDS (Current)

Mira_Ghaly_0-1592699551383.pngMira_Ghaly_1-1592699625176.png

 

Please check my Blog Post:  https://onlinemgblog.wordpress.com/2020/06/21/cds-and-multiselect-optionset/

 

If you found this is useful please mark my solution as a solution!

View solution in original post

1 REPLY 1
Highlighted
Solution Supplier
Solution Supplier

Re: Multi-Select Option Set CDS in Power Automate - Not Available

Hi @dpoggemann 

Please try using the Common Data Services current connector instead of the Common Data Service. 

 

To use the CDS current connector your flow must be created from inside a solution. 

 

I have made a trial on the same and i could get the value using CDS (Current)

Mira_Ghaly_0-1592699551383.pngMira_Ghaly_1-1592699625176.png

 

Please check my Blog Post:  https://onlinemgblog.wordpress.com/2020/06/21/cds-and-multiselect-optionset/

 

If you found this is useful please mark my solution as a solution!

View solution in original post

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

Join the new Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Users online (8,043)