cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
manojmittal
Advocate II
Advocate II

Not able to add Flow to Solution with SharePoint Online Connector

Hello Experts,

 

I am facing strange issue, i create a power automate virtual assistant, As i created topic and added flow with sharepoint online  connector to read data. I saved the flow and try to add the same to solution via Solution -> Add exisitng flow -> Outside Solution. It doesn't appear.

 

Power Automate with SPO Connector.

1.PowerAutomateWithSPOConnector.png

 

Try to add flow to solution after completion. It's not appearing

2.PowerAutomateSPOConnectorDoesnotappear.png

 

When i removed SPO Connector from flow and it start appearing.

3.PowerAutomatewithoutSPOconnector.png

 

Now try to add flow to solution and it start appearing

4.PowerAutomateRemovedSPOConector.png

 

Is it expected behaviour, Power Automate Virtual assistant flow doesn't support sharepoint online connection. 

 kindly suggest experts,  @yashag2255   @Pstork1  @ScottShearer 

 
 
1 ACCEPTED SOLUTION

Accepted Solutions

Hi @manojmittal 

 

I directly created the flow in a solution and it worked as expected. The limitation still exists when you try to move an already created flow that uses SP connections to a solution!

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

7 REPLIES 7
Pstork1
Dual Super User III
Dual Super User III

This is one of the known limitations for Power Automate Solutions.

  • Flows that connect to SharePoint are not available in solutions.

 

This is from the list of limitations found here:

https://docs.microsoft.com/en-us/powerapps/maker/common-data-service/use-solution-explorer#known-lim...



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

I am quite surprised to see below article https://www.c-sharpcorner.com/article/how-to-add-action-to-a-bot-using-microsoft-power-automate/ . Author has created a power automate virtual assistant two weeks before and it 's not working now. 

Pstork1
Dual Super User III
Dual Super User III

I'm not sure what that has to do with the virtual assistant flow not being visible in the solution.  That's been a limitation all along.  I believe the virtual assistant capability is still in preview.  That means it probably won't be guaranteed to be stable until it exits Preview.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

@yashag2255  I saw your video with Jon. https://www.youtube.com/watch?v=Xxad-kSLQ9Y . Could you please suggest, how it was working. is that feature removed now ?

 

@Pstork1 Thanks for your efforts.

Hi @manojmittal 

 

I directly created the flow in a solution and it worked as expected. The limitation still exists when you try to move an already created flow that uses SP connections to a solution!

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

Hi @yashag2255 ,

 

Your comments and the comments from this article - https://flow.microsoft.com/en-us/blog/october-updates-for-microsoft-flow/ suggests that the solutions now support the flows with SharePoint connections, but the comments from @Pstork1 seem to say otherwise. A bit confused with the whole thing - can you confirm if they are supported now and also can you tell how the connections to sharepoint site can be changed when when deployed to a new environment?

 

Thanks,

Vammers

Pstork1
Dual Super User III
Dual Super User III

Let me try to clarify my comments.  You cannot add an existing flow that uses the SharePoint connector to a Solution.  You have to create the flow from inside the context of the Solution.  Once you do that you can add a SharePoint connector.  But you can't add a pre-existing flow.  It doesn't show up, as you already saw.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Users online (3,457)