cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
New Member

Object reference not set to an instance of an object when connecting to Dynamics NAV

Hi all,

 

I'm trying to connect Flow to Dynamics NAV 2017, and to send an email each time a record is created in either the CustomerList Page or MyCustomers query.

 

I've successfully connected Flow to the Dynamics NAV 2017 OData service (I can tell because it can read the Queries, Pages and fields within both).

 

However, when I try to run the Flow, I get an error, saying 'Object reference not set to an instance of an object'.

 

The error message looks like the image attached below.

 

Does anyone have any ideas why this happens? There's no templates to copy from so I'm sure I might have done something incorrect - people appear to have had similar issues using Dynamics CRM but no clear fix for them.

 

Thanks!

 

Error 1.png

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
New Member

Re: Object reference not set to an instance of an object when connecting to Dynamics NAV

So...turns out I solved my own question, via another forum post.

 

https://powerusers.microsoft.com/t5/Flow-Forum/Dynamics-NAV-2016-connector-issues-Invalid-Mashup/m-p...

 

I used the OData rather than OData4 address and the Flow was successful, in case anyone else experiences the same thing.

 

View solution in original post

3 REPLIES 3
Highlighted
New Member

Re: Object reference not set to an instance of an object when connecting to Dynamics NAV

So...turns out I solved my own question, via another forum post.

 

https://powerusers.microsoft.com/t5/Flow-Forum/Dynamics-NAV-2016-connector-issues-Invalid-Mashup/m-p...

 

I used the OData rather than OData4 address and the Flow was successful, in case anyone else experiences the same thing.

 

View solution in original post

Highlighted
Community Support
Community Support

Re: Object reference not set to an instance of an object when connecting to Dynamics NAV

Thanks for the update and sharing.

Regards

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
New Member

Re: Object reference not set to an instance of an object when connecting to Dynamics NAV

Hi Steve,

 

We also have a need to send emails during certain record creations, it seems you were able to accomplish this, can you point me in the rigth direction on how to get started or some examples on how we can do this in NAV 2017?

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Users online (6,613)