cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Mirkos
Frequent Visitor

On Premises Data Gateway and SharePoint On Premises with FBA authentication enabled issue

Hi all,
I have an issue when i try to connect my SharePoint on premises with Microsft Flow's flow.
This is My Envirorment:
SharePoint 2016 On Prmises with FBA authentication enabled;
On Premises Data Gateway v 14.16.6808.1 (sept. 2018);
Microsoft Flow's flow;

The focus of my project it's copy the data from an Excel table shared via OneDrive for business and paste the data in a SharePoint list.

When i try to debug my flow it's returns this error when flow try to connect to SharePoint by On Premises Data Gateway:
Code 502
Message: BadGateway
Received error payload from gateway service with ID 827355: Error parsing UserName '<PI>adminGDPRsp</PI>'..\r\nclientRequestId:eb5d1a4e-2f76-4c3b-a73a-e303dbf26d74"

The office 365 user registered on the gateway is a local administrator on the server and a site collection administrator on SharePoint.

What's wrong?

It's the first time that i find this error, it's possible that the connection from SharePoint OnPrem and On Premises data Gateway don't work when Form Based Authentication is enabled?

Thanks
Mirko

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support
Community Support

Re: On Premises Data Gateway and SharePoint On Premises with FBA authentication enabled issue

Hi @Mirkos,

 

Thanks for feedback. I am afraid that it is a feature that has not been supported yet. I have seen a similar request on Flow Ideas Forum, please vote and comment the idea at here:

https://powerusers.microsoft.com/t5/Flow-Ideas/Microsoft-Flow-on-Onpremise-Enviroment-with-FBA-and-C... 

 

Best regards,

Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

1 REPLY 1
Community Support
Community Support

Re: On Premises Data Gateway and SharePoint On Premises with FBA authentication enabled issue

Hi @Mirkos,

 

Thanks for feedback. I am afraid that it is a feature that has not been supported yet. I have seen a similar request on Flow Ideas Forum, please vote and comment the idea at here:

https://powerusers.microsoft.com/t5/Flow-Ideas/Microsoft-Flow-on-Onpremise-Enviroment-with-FBA-and-C... 

 

Best regards,

Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
firstImage

New Ranks and Rank Icons released on April 21!

The time has come: We are finally able to share more details on the brand-new ranks coming to the Power Automate Community!

firstImage

Now Live: Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Community Summit North America

The top training and networking event across the globe for Microsoft Business Applications

Top Solution Authors
Top Kudoed Authors
Users online (1,079)