cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
servicesGB95
Advocate I
Advocate I

Overwrite file when creating a file in SharePoint

Hey guys,

in the recent flows I created it was normal that an existing file in SharePoint was simply overwritten when it had the same name as the new file. 
Right now I am creating a flow and Automate doesn't behave like this anymore, whenever I try to create a file with the same name I get an error.
Any solutions for that?

Thanks, Julian

1 ACCEPTED SOLUTION

Accepted Solutions
bkeano
Resolver I
Resolver I

Hi

 

I found a solution to this that means you don't have to put in conditions\scopes on whether the file is already there

Not sure if this a recommended long term best practice, but it works.

I also had old flows that did overwrite the file in SharePoint, but as above new 'Create file' does not allow it.

 

So I looked at one of the Microsoft Automate templates 'Copy new files from PC to SharePoint' 

I copied to clipboard the 'Create file' action from that template into the flow I was having problems with, cleared existing fields in it action and replaced them with my own and it worked, it overwrote the files.
I suspect you could also copy from an old flow that worked in the same way.

 

So from this I gather when Microsoft make changes to these actions they make it so it only applies if you are adding the 'action' from new. So if it worked on an older flow, then copy that action from the older flow and you should have the old situation.

Not sure if this issue is a bug on new action or intentional from Microsoft.

Give a thumbs up if this works for you, as it cost me a lot of time trying to get a workaround in place when the solution , in the end , was very simple and hidden in plain sight!

BTW: Versioning is turned on in my site, so solution is not there

 

View solution in original post

18 REPLIES 18
nbot
Regular Visitor

I am experiencing the same issue....very strange

Mira_Ghaly
Dual Super User II
Dual Super User II

@nbot 

I have recently experienced the same issue in flow but i believe it is much related to sharepoint versioning rather than flow.

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here

Did you find any solution for that? The weird things is that it only occurs at "new flows", my old ones still function normally... 

cvaldez83
New Member

I'm having same issue.  My new flow will not overwrite the csv file but yet another older flow that I created a few months ago is able to overwrite its file.

PowerMic
Frequent Visitor

Try to use the "Update File" action if the file exists.

Whats the best way to check if file exists?

bkeano
Resolver I
Resolver I

Hi

 

I found a solution to this that means you don't have to put in conditions\scopes on whether the file is already there

Not sure if this a recommended long term best practice, but it works.

I also had old flows that did overwrite the file in SharePoint, but as above new 'Create file' does not allow it.

 

So I looked at one of the Microsoft Automate templates 'Copy new files from PC to SharePoint' 

I copied to clipboard the 'Create file' action from that template into the flow I was having problems with, cleared existing fields in it action and replaced them with my own and it worked, it overwrote the files.
I suspect you could also copy from an old flow that worked in the same way.

 

So from this I gather when Microsoft make changes to these actions they make it so it only applies if you are adding the 'action' from new. So if it worked on an older flow, then copy that action from the older flow and you should have the old situation.

Not sure if this issue is a bug on new action or intentional from Microsoft.

Give a thumbs up if this works for you, as it cost me a lot of time trying to get a workaround in place when the solution , in the end , was very simple and hidden in plain sight!

BTW: Versioning is turned on in my site, so solution is not there

 

View solution in original post

EnriqueC
Advocate I
Advocate I

Turning "Allow chunking" OFF in the Create File settings worked for me. 

EnriqueC_0-1602018799274.png

 

Does this do anything else? 

It is mentioning "HTTP",  does this imply that data is transferred to SP over HTTP? 

AK3800
New Member

@bkeano can you look at the code behind the action that works and share the results here?  You can use the Peek Code option from the menu on the action to compare what it is doing, it's possible there is some other parameter being included.  I am having the same issue but don't have an action that works to copy.  thank you

@AK3800 , please see below, I replaced our tenant name and site name, but the rest is the peek code from the create SP file
{
"inputs": {
"host": {
"connection": {
"name": "@parameters('$connections')['shared_sharepointonline_1']['connectionId']"
}
},
"method": "post",
"body": "@body('Get_file_content_using_path')",
"path": "/datasets/@{encodeURIComponent(encodeURIComponent('https://TENNANT.sharepoint.com/sites/OURSite'))}/files",
"queries": {
"folderPath": "/Shared Documents",
"name": "@triggerBody()?['Name']"
},
"authentication": "@parameters('$authentication')"
},
"metadata": {
"flowSystemMetadata": {
"swaggerOperationId": "CreateFile"
}
}
}

Luber
Frequent Visitor

My issue is similar; I get the "file already exists" error for files that previously existed but have since been deleted.

The flow basically takes files as input when put into one folder then sorts them into different subfolders and renames them, but (because PA does not have an option to move files) it actually creates a new file with same content but a different name and path and then deletes the original.

Flow ran fine the first time, but when testing, I ran it several times, now it won't (re)create the new files, even though I manually deleted them from the subfolders between tests.

According to the MS documentation, Create File should always overwrite, so there should be no need to do a test if file exists then either update or create new.

https://docs.microsoft.com/en-us/connectors/filesystem/#create-file

I tried turning off chunking, no luck (makes no sense anyway).

The workaround bkeano used, to copy older Create File module, is yet another example of how broken PA is. Not to mention a PITA because of another charming feature of Power Automate: it won't let you copy and action from your clipboard into an Apply to Each module, which I have about a dozen of here.
My workaround: instead of create new file, I used Copy File and that has the option to replace existing file:

Screenshot - 1_5_2021 , 9_59_32 AM.png

Turning off 'Allow Chunking' worked for me.  

AudiTTR
New Member

Yep - turning off 'Allow Chunking' also worked for me too.  Strange, but, it works

That worked perfectly for me!  Thanks!

I don't know why that works @EnriqueC but it does,

I don't see anything in the docs that would make sense for this, but thanks!

dallenap
Advocate I
Advocate I

Turning off "Allow chunking" worked for me also.

 

Don't know why but it solves the problem.

percy_2112
New Member

Hi,
The overwrite functionality was present in old version. But Microsoft removed that functionality in new version of Create File at SharePoint.
I make it enable the overwrite in new flow, with some code changes.
When i compare the code with old to new flow then it noticed there is extra part added in new version and due to that overwrite is disabled in new flow.
If you remove the runtimeConfiguration part from create file json code, overwrite will work in new flow too.
Try to remove the below code in logic app.
"runtimeConfiguration": {
"contentTransfer": {
"transferMode": "Chunked"
}
}
It worked for me . 🙂

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

Users online (82,634)