cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Lukas1
Advocate II
Advocate II

Populate a word template: Wrong allocation of array-values and template-fields

Hi,

 

I have a word template with a repeating section. The repeating section contains fields which are populated with values from an array.

 

For any reason the values are not put into the right fields. A test-run of the flow shows that the values are assigned correctly in the "populate a word template"-function, but in the word file the values are showing up in the wrong fields.

 

Some fields aren't populated at all.

 

This is how I append values to the array:

This is how I append values to the array.This is how I append values to the array.

Test shows that the values are assigned correctly.Test shows that the values are assigned correctly.

In the word file the value of "Battery_O_Evaluation" is shown in field "Battery_O_Status". The field "Battery_O_Evaluation" keeps blank.In the word file the value of "Battery_O_Evaluation" is shown in field "Battery_O_Status". The field "Battery_O_Evaluation" keeps blank.

 

 

3 REPLIES 3
yashag2255
Dual Super User II
Dual Super User II

Hi @Lukas1 

 

I have blog post on working with word templates. Can you check here and match if you have correctly configured the word template and then the flow: https://www.bythedevs.com/post/how-to-populate-a-word-template-with-repeating-control  

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

@yashag2255, thanks for your reply. I read your blog post and found two differences:

 

1. I created the repeating section first, then I added the fields within the repeating section. I will try it the other way around, but I don't have much hope.

 

2. In your array you add a "-" after each value. What is that for?

Bildschirmfoto 2020-03-07 um 10.20.08.png

 

Thanks,

Lukas

yashag2255
Dual Super User II
Dual Super User II

Hi @Lukas1 

 

It is not a "-" it is a "," after each value only until the last but one value for creating appropriate JSON object. 

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Helpful resources

Announcements
MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Users online (47,086)