cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Blair24
Frequent Visitor

PowerApps Collection via Flow into JSON

Hi Folks,

Struggling to get this to work for an item that has multiple values. I have a collection in PowerApps that contains "SiteName" and "SiteURL". Im trying to pass these values into Flow so I can create a SharePoint List item and pass them onto an Azure Queue in JSON for each item in the collection.

 

I can get in to work for either "SiteName" or "SiteURL", but not both combined. I'm not sure how to split the string when there's two fields in the string that are being passed to Flow - any suggestions?


Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions

Hey,

Yeah I eventually got it working after a lot of trial and error....

 

Think in total I've got 6 or 7 different steps to transform the string back into JSON then parse it to get the values out. Hopefully there's something in the works to make it easier in the future!

 

The compose kept adding '\' back into the split value... which threw me

View solution in original post

4 REPLIES 4
aprildunnam
Power Participant
Power Participant

At the moment, PowerApps doesn't naitvely support passing record values to Flow, it only supports passing string values.  To handle this you'll have to do a work-around and do some string manipulation on the Flow side.  If I'm understanding your need correctly I think this solution is helpful:  https://powerusers.microsoft.com/t5/General-Discussion/How-to-supply-a-record-parameter-to-Flow-from...

 

Check out the marked solution and look at the work-around that is supplied and let me know if that helps.

Hey,

Yeah I eventually got it working after a lot of trial and error....

 

Think in total I've got 6 or 7 different steps to transform the string back into JSON then parse it to get the values out. Hopefully there's something in the works to make it easier in the future!

 

The compose kept adding '\' back into the split value... which threw me

View solution in original post

Yeah it does require several steps to get the data manipulated correctly.  I hope it's something they are working on improving.  Glad you got it working!

v-yuazh-msft
Community Support
Community Support

Hi @Blair24,

 

It seems that your problem has been solved.

If yes, please go ahead and mark the post as solved by clicking “Accept as Solution” so that this thread will be marked for other users to easily identify!

 

Best regards,

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Users online (2,731)