cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

PowerApps custom form not opening for use in IE 11

I am trying to open the customized edit/new form (/Editform.aspx?ID=xx) in ie11. I have created the forms using Poweapps. And in ie 11 its showing loading image.Error message in F12, 'Promise' is undefined'.

 

Thanks

Parvathy

 

Issue-poweapps custom form in ie11.png

4 REPLIES 4
Highlighted
Community Support
Community Support

Re: PowerApps custom form not opening for use in IE 11

Hi @Parvathy,

 

Are you using SharePoint custom forms? Have you tried clear cache on IE or open it in an InPrivate mode?

 

To test this issue, I create a custom form on IE and it works fine without any issues.

 

Could you please clear cache then try again with it? If you are still having the issue, please feel free post back.

 

Besides, please post PowerApps related issues on PowerApps forum so that you could get the most qualified solutions for you issues. Thanks for your understanding.

 

 

Best regards,

Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Frequent Visitor

Re: PowerApps custom form not opening for use in IE 11

Hi @Mabel Mao

 

Thanks for the reply. I am using powerapps custom form.I have tried clear cache on IE or open in an Inprivate mode.

 

But its not working. Today i am getting this "Unable to get property 'peek' of undefined or null reference" error in IE in Developer tools. But its working for chrome and Edge browser. Its showing error only when we are using the direct url. eg:/list/listnam/editform.aspx?id=xx

 

Thanks

Parvathy

Highlighted
Frequent Visitor

Re: PowerApps custom form not opening for use in IE 11

Currently this is working for IE 11. I think the issue is resolved by the microsoft.

Highlighted
Frequent Visitor

Re: PowerApps custom form not opening for use in IE 11

This issue does not appear to be resolved.  I have created a SharePoint custom form and it loads without issue in both Chrome and Opera.  In IE 11, the loading image persists and there is an alert: "Promise undefined."  As suggested previously in this thread, I tried clearing cache but that didn't correct the problem.  Expecting our users to open it in private mode is not practical, so I didn't pursue that suggestion.

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

Join the new Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Users online (8,488)