cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Post Patron
Post Patron

Powerapp Combox always returns false in flow condition

I have a powerapps combox when checked within powerapps returns a text value of true.  I have verified this within powerapps and also writing the value to a Sharepoint list from flow, works fine.  When using the same value within a flow condition it always returns false.  I believe this is a common issue and I thought I have dealt with it before however can't remember the procedure to allow the condition to respect the value of the combox.

 

PowerApp Button

'PowerApp->Postamessage(V3)'.Run(TeamsChannelCombo.Value, TeamsChannelCombo.Value)

 

2019-08-22_20-44-35.jpg2019-08-22_20-45-04.jpg2019-08-22_20-45-25.jpg

1 ACCEPTED SOLUTION

Accepted Solutions

Hi @Dudditz 

 

The condition_objectname should be coming from dynamic content

currently you have hardcoded it as a string

 

when in expression window

type bool() then switch to dynamic content and add the dynamic param value for condition_objectname

View solution in original post

10 REPLIES 10
Dual Super User II
Dual Super User II

Hi @Dudditz 

 

Try true as an expression value 

 

Regards,

Reza Dorrani

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly

Hi Reza, can you provide some guidance on how the expression should work?  The configuration below does the same issue, returns false and fails.  test.jpg

I forgot to mention compose returns true, writing to sharepoint returns true, conditions return false regardless of value.

Hi @Dudditz 

 

try bool(paramfrompowerapp) is equal to true

 

Use expressions for both

plz note paramfrompowerapp - is your dynamic content param from powerapps

 

Regards,

Reza Dorrani

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly

Hi Reza, I did as explained and the following error.

 

InvalidTemplate. Unable to process template language expressions for action 'Condition' at line '1' and column '2052': 'The template language function 'bool' was invoked with a parameter that is not valid. The value cannot be converted to the target type.'.
 
bool('Condition_ObjectName') is equal to true
 
Both are setup as expressions

Hi @Dudditz 

 

share screenshot

I am sure I have this configured wrong, not sure why I am so challengA.jpgB.jpged by this concept.

Hi @Dudditz 

 

The condition_objectname should be coming from dynamic content

currently you have hardcoded it as a string

 

when in expression window

type bool() then switch to dynamic content and add the dynamic param value for condition_objectname

View solution in original post

Well that was to obvious, thanks for pointing that out, my mistake.  It is working now.  I have am relativly new to using the flow expressions so this was a good learning experince.  Thanks again for all your help.

@Dudditz 

 

Good luck with your MS Flow learning

 

Check this to learn about expressions

https://www.powerplatformug.com/viewdocument/august-2019-meeting-recording-flo?CommunityKey=e5945313...

 

Regards,

Reza Dorrani

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Users online (1,733)