cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Mary2
Helper I
Helper I

Problem in delay of getting mail notification through FLOW

I have  EMBED FORMS PRO INSIDE A POWER APPS CANVAS APP and sharing that FORM in mail to clients through a FLOW.

But mail not triggering even-though the flow status showing success.

Its taking 5 to 6 hrs to trigger mail.

What is the reason behind this.

10 REPLIES 10
Jcook
Super User III
Super User III

Hello @Mary2 

 

Could you share a screenshot of your flow.


Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips,
tricks, and guides
FlowAltDelete





Mary2_0-1596802194602.png

 

 

Jcook
Super User III
Super User III

@Mary2 

 

Question:

Does the flow work correctly when you trigger from Power Apps?

Or does this happen when anyone triggers it?


Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips,
tricks, and guides
FlowAltDelete





Yes, though the status showing success,im not getting mail...

Mary2_0-1596697448308.png

 

Please Experts,

Waiting for your support!

Jcook
Super User III
Super User III

@Mary2 

 

In the successful run, can you look into the Survey action. And see what the inputs are for all the fields. And if possible share a screenshot of this


Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips,
tricks, and guides
FlowAltDelete





Mary2_0-1596815928973.pngMary2_1-1596816065349.pngMary2_2-1596816107894.png

Mary2_3-1596816129045.pngMary2_4-1596816147344.png

 

Jcook
Super User III
Super User III

Hello @Mary2 

 

Since PowerApps uses all the connections based on the user in the power app. Can you try sharing the form with the users who are triggering the power app


Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips,
tricks, and guides
FlowAltDelete





Hi Expert,

Thank you for your support...

 

Now, i come to know the problem is with changing the default sender's mail id from surveys@email.formspro.microsoft.com to survey@ourcompany.com

So when we change this we are getting problem like not triggering mail...

 

Why happening like this, any idea and suggestions needed to resolve the issue...

 

 

Thanks in advance 

Experts,

 

Please support me....

Waiting for your response...

 

 

Thank You!

Helpful resources

Announcements
MPA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

R2 (Green) 768 x 460px.png

Microsoft Dynamics 365 & Power Platform User Professionals

DynamicsCon is a FREE, 4 half-day virtual learning experience for 11,000+ Microsoft Business Application users and professionals.

Users online (1,172)