cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
kahyong
Level: Powered On

Problem of sending multiple email.

User can delete record based on ID search in the excel file. If ID can't found in the Excel will send back email.

 

my problem is, if i have 10 records in Excel, it will return 1 true value and 9 false values.

 

Means user will receives number of email according how many record in the Excel.

 

How can i fix only send one email to user if record can't found.Capture.PNG

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support Team
Community Support Team

Re: Problem of sending multiple email.

Hi @kahyong ,

 

Could you share your specific configuration, it seems that you did not configure Flow according to the screenshots I provided.

This is its structure:

2.PNG

Please take a try again.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

4 REPLIES 4
Super User
Super User

Re: Problem of sending multiple email.

@kahyong :

It appears as though your condition is always evaluating to False.  Can you check one of your runs where the record is there and see if the condition ever returns true? 

If it never returns true, then the issue is with your condition.  If this is the case, you might try using an expression to convert the ID value from Forms to a number inside of your condition.

 

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott
Community Support Team
Community Support Team

Re: Problem of sending multiple email.

Hi @kahyong ,

 

You could try filtering the record using Filter Query.

Use ID submitted by the form as the filter condition, and then use length() function to determine whether there is a qualified record. If there is, execute the delete operation; if not, send the email.

Expression reference:

length(body('List_rows_present_in_a_table')?['value'])

Image reference:12.PNG

 

13.PNG

 

Hope it helps.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
kahyong
Level: Powered On

Re: Problem of sending multiple email.

Thank you for your solution.

Community Support Team
Community Support Team

Re: Problem of sending multiple email.

Hi @kahyong ,

 

Could you share your specific configuration, it seems that you did not configure Flow according to the screenshots I provided.

This is its structure:

2.PNG

Please take a try again.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors (Last 30 Days)
Users online (5,359)