cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Problem of sending multiple email.

User can delete record based on ID search in the excel file. If ID can't found in the Excel will send back email.

 

my problem is, if i have 10 records in Excel, it will return 1 true value and 9 false values.

 

Means user will receives number of email according how many record in the Excel.

 

How can i fix only send one email to user if record can't found.Capture.PNG

1 ACCEPTED SOLUTION

Accepted Solutions

Hi @kahyong ,

 

Could you share your specific configuration, it seems that you did not configure Flow according to the screenshots I provided.

This is its structure:

2.PNG

Please take a try again.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

4 REPLIES 4
Highlighted
Super User III
Super User III

@kahyong :

It appears as though your condition is always evaluating to False.  Can you check one of your runs where the record is there and see if the condition ever returns true? 

If it never returns true, then the issue is with your condition.  If this is the case, you might try using an expression to convert the ID value from Forms to a number inside of your condition.

 

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott
Highlighted
Community Support
Community Support

Hi @kahyong ,

 

You could try filtering the record using Filter Query.

Use ID submitted by the form as the filter condition, and then use length() function to determine whether there is a qualified record. If there is, execute the delete operation; if not, send the email.

Expression reference:

length(body('List_rows_present_in_a_table')?['value'])

Image reference:12.PNG

 

13.PNG

 

Hope it helps.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted

Thank you for your solution.

Hi @kahyong ,

 

Could you share your specific configuration, it seems that you did not configure Flow according to the screenshots I provided.

This is its structure:

2.PNG

Please take a try again.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Users online (12,110)