cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Problem with Forms Pro and FLOW

Hello,

 

i have a Problem that i receive every time error 400 if i create a FLOW for an Forms PRO Form.

 

{
"ErrorMessage": "System.AggregateException: One or more errors occurred. ---> System.NullReferenceException: Object reference not set to an instance of an object.\r\n   at Microsoft.Forms.Pro.ApiFacade.RequestHandlers.SendEmailsForFlowRequestHandler.<ParseRequestData>d__11.MoveNext()\r\n   --- End of inner exception stack trace ---\r\n   at System.Threading.Tasks.Task.ThrowIfExceptional(Boolean includeTaskCanceledExceptions)\r\n   at System.Threading.Tasks.Task`1.GetResultCore(Boolean waitCompletionNotification)\r\n   at System.Threading.Tasks.Task`1.get_Result()\r\n   at Microsoft.Forms.Pro.ApiFacade.RequestHandlers.SendEmailsForFlowRequestHandler.DoValidate(HttpRequestContext requestContext)\r\n---> (Inner Exception #0) System.NullReferenceException: Object reference not set to an instance of an object.\r\n   at Microsoft.Forms.Pro.ApiFacade.RequestHandlers.SendEmailsForFlowRequestHandler.<ParseRequestData>d__11.MoveNext()<---\r\n"
}
When i try to start an normal TRIGGER TEST.
 
When i create the FLOW from Forms PRO it enters this KEY as an Survey.
{"source":"la-draft-clipboard","value":[{"tokenKey":"F6A39990-F28D-49FE-A072-78EB0AEA9F54","type":"literal","tokenExpression":"aKxJ776eHk6vdhYmKtVm1NSgxS12WntOmbyZ51zZBUZUOUZNWTBCVVlKUk85V1RGUDlLUlhRU1FBSS4u"}]}
 
In Forms PRO the FLOW will be identified for my Survay!!!!!
 
But when i try to look to the lookup in FLow i found nothing...
Unbenannt.PNG
Any Ideas? Forms Pro was not operable at this time!
 
 
 
7 REPLIES 7
Highlighted
Resident Rockstar
Resident Rockstar

Re: Problem with Forms Pro and FLOW

Hi @thomasczerwinsk , thank you for your post in the Flow Community.

 

I was wondering, could you post pictures of your complete Flow and I will try and recreate this please?

 

If you have found my post helpful, please mark thumbs up.

 

Any other questions, just ask.

 

Thanks, Alan

 


Did I answer your question? Mark my post as a solution!

Proud to be a Flownaut!


Highlighted
Regular Visitor

Re: Problem with Forms Pro and FLOW

I experience the same issue across multiple environments. I am trying to send a survey based on a D365 record being updated.

 

It occurs across multiple tenants and also while using the Flow templates unmodified.

 

Please find screenshots below - 

 

The error when I try to select a templateThe error when I try to select a templateAdding a custom value of the survey ID (as used in the Flow templates)Adding a custom value of the survey ID (as used in the Flow templates)The error experienced when tested in my FlowThe error experienced when tested in my FlowThe error experienced when using the Flow templateThe error experienced when using the Flow template

Highlighted
New Member

Re: Problem with Forms Pro and FLOW

Seeing the same errors when using "Forms Pro" and "Dynamcis 365".

Anyone got to the bottom of this yet?

Highlighted
Regular Visitor

Re: Problem with Forms Pro and FLOW

I have the same problem.

Highlighted
New Member

Re: Problem with Forms Pro and FLOW

I'm hoping someone soon will reply with the magic solution Smiley Happy

Highlighted
New Member

Re: Problem with Forms Pro and FLOW

I assume no one has had any break throughs with this?

Highlighted
Regular Visitor

Re: Problem with Forms Pro and FLOW

Sorry, I haven't.

 

I think it's got something to do with the environment Forms Pro is initially installed on.

 

My findings are that in tenants where I've used Forms (the original version) before registering for the Forms Pro preview are unaffected. Also, on the tenants that are affected - I am experiencing other strange issues e.g. I can create a new model driven app but when I try to save it I get an error saying that the appmodule ID doesn't exist. This suggests that it may be trying to save it to a different envioronment than it was created in. It's a known issue Microsoft are trying to address.

 

Sorry, this doesn't resolve anything but these are just my observations.

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Users online (5,296)