cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Beerman212
Frequent Visitor

Recent change "Create Sharing Link" now requires GUID for list

I've had a number of flows that broke recently due to what seems like a change to the platform that the action "Create Sharing Link" now requires GUID for the library.  In the interest of creating an easily transferrable workflow, I had set up some compose fields to scrape some information like the id of the document libraries that I'm using.

recently, I've had one workflow that has started failing, and near as I can tell, it's because the "Create Sharing Link" action now requires a guid for the Library that you're referencing instead of allowing me to pass dynamic content I.E. the library name.

Error:

 

"body": {
        "error": {
            "code": "invalidRequest",
            "message": "The list ID must be provided in Guid form."
        }
    }

 

1 ACCEPTED SOLUTION

Accepted Solutions
Beerman212
Frequent Visitor

Well, if anyone is interested, there is a way to programatically get the GUID using the HTTP request action to sharepoint.

Here is what I did.

Get GUID for a Document LibraryGet GUID for a Document Library

 

found the solution here: https://powerusers.microsoft.com/t5/Building-Flows/Get-SharePoint-Document-Library-GUID-using-the-Do... 

View solution in original post

6 REPLIES 6
Beerman212
Frequent Visitor

PowerAutomateIssue.PNG

 

This no longer works.  Is there a way to programatically get the guid for a doc library?

shweta_salve
Frequent Visitor

We've started facing the same issue, Can anyone please provide a solution to this issue? Not sure how to get a list ID in the GUID format and where can we find this GUID value.

RFSDP
New Member

We're experiencing the same issue which started on the 30th according to logs of failed Flows 

 

However if appears to be fixed now (?) as couple of runs this morning have worked.

 

Does anyone know (Microsoft?) if this was a newly introduced bug that has subsequently been removed or exactly what the situation is on this?

 

Thanks Derek

shweta_salve
Frequent Visitor

Hi @RFSDP , thanks for the update, it's started working for us as well not sure what has happened, however, we have raised a ticket with the Microsoft support team and they are investigating a root cause.

Beerman212
Frequent Visitor

Well, if anyone is interested, there is a way to programatically get the GUID using the HTTP request action to sharepoint.

Here is what I did.

Get GUID for a Document LibraryGet GUID for a Document Library

 

found the solution here: https://powerusers.microsoft.com/t5/Building-Flows/Get-SharePoint-Document-Library-GUID-using-the-Do... 

v-yujincui-msft
Community Support
Community Support

Hi @Beerman212 ,

 

Thanks for sharing.

 

Maybe you could try to consider marking your answer as a 'Solution' so that it will be useful for others and close the case.

 

Best Regards,
Charlie Choi

Helpful resources

Announcements
Power Automate News & Announcements

Power Automate News & Announcements

Keep up to date with current events and community announcements in the Power Automate community.

Power Automate Community Blog

Power Automate Community Blog

Check out the latest Community Blog from the community!

Users online (2,651)