cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Recurring schedule not working at the right time

Hello there.  I have created multiple flows.  Each has  recurring schedule.  One runs at 3 AM, another at 10:00 AM and the last at 2:00 PM.  This is all for Central Time (Chicago).  The 3 AM one runs fine and starts at 3 AM.  However, the 10:00 AM and 2:00 PM run at 10:51 AM and 2:51 PM respectively.  I have set each back an hour, but, considering the current behavior, this will actually cause them to go 9 minutes early, which is less than preferred.  Are there ay known bugs within certain time zones (regions?) that cause this sort of behavior?  Any help would be greatly appreciated. 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Frequent Visitor

I found the fix.  Was directed by https://powerusers.microsoft.com/t5/Using-Flows/Recurrence-set-for-10-but-ran-at-9-22/m-p/241400 .  The issue was due to no Start time being defined, even though the time zone was correct and the times were selected for the correct hours.  Not sure why this is a thing, especially since there is no information for start time showing that it is required.  I think MS should look more into this so that others can understand what is needed when creating a recurrence trigger.  I added the start time and triggering is successful at the set times. 

tdickson_0-1603801873169.png

 

View solution in original post

2 REPLIES 2
Highlighted
Super User III
Super User III

Hello @tdickson 

 

Could you share some screenshots of the Flows that are triggering at the wrong times.





Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips, tricks, and guides
FlowAltDelete




Highlighted
Frequent Visitor

I found the fix.  Was directed by https://powerusers.microsoft.com/t5/Using-Flows/Recurrence-set-for-10-but-ran-at-9-22/m-p/241400 .  The issue was due to no Start time being defined, even though the time zone was correct and the times were selected for the correct hours.  Not sure why this is a thing, especially since there is no information for start time showing that it is required.  I think MS should look more into this so that others can understand what is needed when creating a recurrence trigger.  I added the start time and triggering is successful at the set times. 

tdickson_0-1603801873169.png

 

View solution in original post

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Users online (9,899)