cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
muges01
Helper II
Helper II

Run Excel script error when passing dynamic file

Hi everyone, 

 

I'm trying run the excel script preview option dynamically on newly created file but i'm getting and error "The parameter 'file' has an invalid value '/Data-03.xlsx'.".

 

The following is my power automate

muges01_0-1594250055699.png

 

Do anyone know how to pass the file dynamically?

 

The goal of this script is the office script to clean the updated file before the user can utilise them.

 

Thank you in advanced.

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

Hi @muges01 

 

Instead of 'File name with extension' use 'Identifier'. That should work. This is documented here https://docs.microsoft.com/en-gb/connectors/excelonlinebusiness/#known-issues-and-limitations

GeoffRen_0-1594832639318.png

 

View solution in original post

5 REPLIES 5
yashag2255
Dual Super User II
Dual Super User II

Hi @muges01 

 

Remove everything from the file and search for identifier from dynamic selector and provide that for the file. Can you try this and see if this resolves the issue? 

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Hi @yashag2255  are you referring to remove the everything and specify the file name dynamic? If so i have done that and is not working.

Hi @muges01 

 

Instead of 'File name with extension' use 'Identifier'. That should work. This is documented here https://docs.microsoft.com/en-gb/connectors/excelonlinebusiness/#known-issues-and-limitations

GeoffRen_0-1594832639318.png

 

View solution in original post

Hi @GeoffRen,

 

That did the trick... Thank very much.

Hi @GeoffRen ,

 

The flow failed for all of them except the first one, wen i drop couple file in the library.

The error message that i'm getting 

We were unable to run the script. Please try again.
The server experienced an issue and couldn't run the script. Please try again in a few moments.

How can i overcome this issue?

Helpful resources

Announcements
MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Users online (89,179)