cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Morghan
Level: Powered On

Run flow on Condition

Hello,

 

My issue right now is that I all of a sudden cannot get my flow to trigger based off a condition that was working last week. Simply put, my requirement is that I need this particular flow to trigger when the "Status" of an already existing item in a list is changed from "New" to "Rejected." I am using the 'When an item is created or modified' trigger and have the condition set to: @not(equals(triggerBody()?['Status']?['Value'],'New')) 

 

I then have a Condition step where "Status Value" = Rejected and from there, if true, should send an email to the item creator. However, the Condition is ONLY resolving to FALSE. Screenshot of what I have: 

 

Full_FLow.pngStatus_Value.png

 

 

 

 

If needed, please see my previous post here: https://powerusers.microsoft.com/t5/General-Flow-Discussion/Move-items-attachments-between-locations... for additional context...

 

1 ACCEPTED SOLUTION

Accepted Solutions
Dual Super User
Dual Super User

Re: Run flow on Condition

Hi @Morghan 

 

Can you try selecting the Status Value from the dynamic selector? I think it should be triggerbody() instead of triggeroutputs()

 

SS:

ee45.PNG

 

Also, is this a multi select choice column?

 

Hope this helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

8 REPLIES 8
leyburn19
Level 10

Re: Run flow on Condition

Try simply changing to contains instead of equal to.  It might work

Dual Super User
Dual Super User

Re: Run flow on Condition

Hi @Morghan 

 

Can you try selecting the Status Value from the dynamic selector? I think it should be triggerbody() instead of triggeroutputs()

 

SS:

ee45.PNG

 

Also, is this a multi select choice column?

 

Hope this helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

Morghan
Level: Powered On

Re: Run flow on Condition

Hi @leyburn19 - thank you for the suggestion, unfortunately using "Contains" did not work either. The trigger still will not fire. 

 

@yashag2255 - Both 'Status' and 'Status Value' dynamic contents are using 'triggerOutputs' instead of 'triggerBody':

 

This is what they both show-

Status Value     triggerOutput()?['body/Status/Value'] 
Status               triggerOutput()?['body/Status/Value']

 

 

Is there anyway to manually change this? 

 

Thank you for your help,

M

Morghan
Level: Powered On

Re: Run flow on Condition

@yashag2255 - The flow just triggered; it just took 17 minutes! Any idea what would cause the delay?? (is it that the Dynamic content is't quite right?)

 

M

Morghan
Level: Powered On

Re: Run flow on Condition

Amount of time it takes the flow to kick off after I've updated the "Status" value:

First test: 17 mins

Second test: 16 mins

Third test: 16 mins

 

Is it depending on the "SharePoint Crawl" to check if items have been modified? @yashag2255 

 

M

Dual Super User
Dual Super User

Re: Run flow on Condition

Hey @Morghan 

 

Are you referring to the total flow run time or the time taken to trigger the flow? If it is time taken to trigger the flow, then that is weird because it should trigger as soon as the item is changed and the save button is pressed in the SP list/form. 

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Morghan
Level: Powered On

Re: Run flow on Condition

Hi @yashag2255  - This morning it's much better; only 1-2 minute delay before the flows are triggering instead of the 17 min delay I was seeing yesterday. I have two total flows: the first is when a new item is created. It looks at a lookup list after the item's created and if it sees the same "name," it marks the Status as Rebusmitted and if it's a new name, marks Status as New. This flow is taking about 60-90 seconds to trigger after the new item's been created.

 

Then the second flow is the one in this thread, and after marking the Status to either Approved or Rejected, it too is taking about the same amount of time before the flow is triggered.. Not the biggest deal in the world, just odd. I have other flows that are immediate, this library seems to be the only one that's delayed. 

Dual Super User
Dual Super User

Re: Run flow on Condition

Hey @Morghan 

 

Thank you for checking that out and updating us. Usually this might happen when you reach the specified API call limit for you tenant and the licensing plan that you are enrolled to. You can get more details on that limitation here: https://go.microsoft.com/fwlink/?LinkId=2085130&clcid=0x409%20

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Users Online
Currently online: 202 members 5,304 guests
Please welcome our newest community members: