cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Anonymous
Not applicable

Send Email Error - Bad Gateway

This error shows on some users.

When it tries to send email fails and show this message. It also fails on resubmit.

 

{
  "error": {
    "code"502,
    "source""msmanaged-na.azure-apim.net",
    "clientRequestId""6bcaa297-ffe2-4515-81f9-65af691e78bc",
    "message""BadGateway",
    "innerError": {
      "status"502,
      "message""Error de solicitud. Vuelva a intentarlo más tarde.\r\nclientRequestId: 6bcaa297-ffe2-4515-81f9-65af691e78bc\r\nserviceRequestId: a5aa9650-086d-4acc-8e31-24624f71f5d8",
      "source""office365-cus.azconn-cus.p.azurewebsites.net"
    }
  }
}

image.png

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Support
Community Support

Re: Send Email Error - Bad Gateway

Hi @Anonymous,

 

Could you please share a full screenshot of your flow's configuration?

Could you please show a bit more about the values filled within the Attachment Name field and the Attachment Content field?

 

I have made a test on my side and don't have the issue that you mentioned. Please check if you have filled proper value within the To field, the Attachments Name field and the Attachments Content field.

 

The Attachment Name field of the "Send an email" action is required to fill a file name including the extension name (e.g. Kris Dai.xlsx). The Attachment Content field is required to fill a binary data. Please check if the values you filled within the Attachments Name field and the Attachments Content field meet the requirements.

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

3 REPLIES 3
Highlighted
Community Support
Community Support

Re: Send Email Error - Bad Gateway

Hi @Anonymous,

 

Could you please share a full screenshot of your flow's configuration?

Could you please show a bit more about the values filled within the Attachment Name field and the Attachment Content field?

 

I have made a test on my side and don't have the issue that you mentioned. Please check if you have filled proper value within the To field, the Attachments Name field and the Attachments Content field.

 

The Attachment Name field of the "Send an email" action is required to fill a file name including the extension name (e.g. Kris Dai.xlsx). The Attachment Content field is required to fill a binary data. Please check if the values you filled within the Attachments Name field and the Attachments Content field meet the requirements.

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Anonymous
Not applicable

Re: Send Email Error - Bad Gateway

The attachment name had a line break and it caused the problem. After I remove the line break from the original data (SQL DB) it runs successfully. Thanks!

Highlighted
Frequent Visitor

Re: Send Email Error - Bad Gateway

I have a 100% replicatable BadGateway error in microsoft flow

 

When the flow receives an unencrypted message, Flow knows how to forward it.

 

When it is an encrypted message, Flow throws a BadGateway  error, even if the OME (Office Message Encryption) allows forwarding.  In my opinion Microsoft should fix this. When a user has the right to forward and the encryption rule allows forwarding then Flow should also be able to forward that message.

 

Bart

 

 

Helpful resources

Announcements
secondImage

August 2020 CYST Winners!

Check out the winners of the recent 'Can You Solve These?' community challenge!

thirdImage

Experience what's new for Power Automate

Join us for an in-depth look at the new Power Automate features and capabilities at the free Microsoft Business Applications Launch Event.

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Users online (3,981)