cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper III
Helper III

Send an HTTP request to update hyperlink column in SP.

Hi,

I'm trying to update a hyperlink column in SP using the 'Send an HTTP request' action, but I keep getting this error: 

 

{
  "status": 400,
  "message": "A type named 'SP.Data.myLinksListItem' could not be resolved by the model. When a model is available, each type name must resolve to a valid type.\r\nclientRequestId: 613869ae-a4b0-4c20-9c13-094718b9959c\r\nserviceRequestId: 6a71ea9e-90d6-8000-e22a-718f2ce0ec8c",
  "source": "https://mytenten.sharepoint.com/sites/"('myLinks')/items(3)",
  "errors": [
    "-1",
    "Microsoft.SharePoint.Client.InvalidClientQueryException"
  ]
}

Below is my configuration:

sendAnHTTPReq.PNG

 

Any ideas?

 

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Super User
Super User

Hi @_sourcecod3_ just a quick check, is the Type correct (including the case)?

 

I wrote this blog post on achieving what you're doing, and came across the purely because I'd miskeyed the type:

https://collab365.community/setting-updating-sharepoint-hyperlink-fields-flow-logic-apps/





Did my reply help? Please give it a thumbs up.
Did I answer your question? Please mark my post as a solution!
If you liked my response, please consider giving it a thumbs up. THANKS!


Proud to be a Flownaut!





Community Leader: Black Country PowerApps & Flow User Group

View solution in original post

4 REPLIES 4
Highlighted
Super User
Super User

Hi @_sourcecod3_ just a quick check, is the Type correct (including the case)?

 

I wrote this blog post on achieving what you're doing, and came across the purely because I'd miskeyed the type:

https://collab365.community/setting-updating-sharepoint-hyperlink-fields-flow-logic-apps/





Did my reply help? Please give it a thumbs up.
Did I answer your question? Please mark my post as a solution!
If you liked my response, please consider giving it a thumbs up. THANKS!


Proud to be a Flownaut!





Community Leader: Black Country PowerApps & Flow User Group

View solution in original post

Highlighted

Hi @_sourcecod3_ ,

 

Please use the following method to get the type value you need.

https://<site>/_api/web/lists/getbytitle('<List Name>')?$select=ListItemEntityTypeFullName

15.PNG

Please check this similar link and see if it helps:

a-type-named-sp-data-listitem-could-not-be-resolved-by-the-model-when-a-model-is-available-each-type...

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted

Hi @MattWeston365 Thanks for your response. I followed your instructions on your post it worked! When I initiated the REST call I found out my 'ListItemEntityTypeFullName' was not 'myLinks' but 'MyLinks'. I updated my 'type' on my JSON body, ran my flow and it updated my links. I just assumed it would use the internal list name.
 
This is good! thanks again Matt!
Highlighted

Hi @v-bacao-msft - this is also the same response and it works as well. Thank you! 

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Top Kudoed Authors
Users online (8,829)