cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper I
Helper I

Send an email does not reach recipients

Hi,

 

I built a flow to send emails to recipients that are outside my organization. The emails are sent using my email address. However, it was brought to my attention that they were not receiving the emails. The flow does not throw any error. What could be the possible reason, and how do I solve this? Thanks!

 

5 REPLIES 5
Highlighted
Memorable Member
Memorable Member

Re: Send an email does not reach recipients

Hey @anmdf 

 

 

Could you share a screenshot of the latest run of your Flow, also make sure we can see what happens in the email action.

Thanks in advance.

 

Kind regards

 

Tom



If this reply has answered your question or solved your issue, please mark this question as answered.

Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up.

Highlighted
Super User III
Super User III

Re: Send an email does not reach recipients

@anmdf 

You may want to speak with your Flow admin to see if there are Data Loss Prevention polices in place that prevet you from sending emails from Flow outside your organization at all times or under certain circumstances.

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott
Highlighted
Helper I
Helper I

Re: Send an email does not reach recipients

Hi @Tom_Slosse @ScottShearer,

 

Unfortunately, I don't have any information of the latest run. But this is my email action (see below). I'll check with my Flow contacts on the DLP policies. Thank you.

 

2019-11-26_12-55-58.png

Highlighted
Memorable Member
Memorable Member

Re: Send an email does not reach recipients

Hey @anmdf 

 

A bit of topic from your problem:

Out of your screenshot I conclude that you send an email per attachment.

You could solve this by adding all the content and names into one variable and send one mail with all the attachments.

 

The reason the mails are not sent to the recipients remains very unclear tho.

So hopefully you get back to us with your DLP policies.

 

Kind regards

 


Tom



If this reply has answered your question or solved your issue, please mark this question as answered.

Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up.

Highlighted
Community Support
Community Support

Re: Send an email does not reach recipients

 

Hi @anmdf ,

 

In addition to checking DLP policies, you need to ensure that Attachments are not empty, you may need to set the Include attachment / Has attachments field to Yes.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Users online (7,714)