cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
techtudoor
Resolver I
Resolver I

Send an email from a shared mailbox (v2) and attach a file from SharePoint

I have a very simple Power Automate Flow (when a new email arrives in a shared mailbox (v2)) --> (Send an email from a shared mailbox (v2)).

This is working just how it needs to, however, I have now been asked to add an attachment to the outgoing email. This has become problematic. The attachment the needs to be attached is located in my SharePoint Online document library. I have tried using Get file content, and this sent the email with a .xmIPK attachment. The file I am trying to attach is a .docx.

 

I am at a loss as to what I am missing to get this to attach to the email. Any assistance is greatly appreciated

1 ACCEPTED SOLUTION

Accepted Solutions

@techtudoor 

It sounds like the same file will be attached all the time.  If so, add the ID column to a view of your library.  Make note of the ID of the document that you want to attach.

Then, follow my example below and let me know if you have any questions.  Don't worry that there is a loop - only 1 email will go out.

image.pngimage.pngimage.png

 

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

View solution in original post

5 REPLIES 5
PG_WorXz10
Resident Rockstar
Resident Rockstar

Hi @techtudoor,

 

Would you try with Get files properties 

 

PriyankaMadan10_0-1627929504852.png

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

If this post was helpful or you need more help please consider giving Thumbs Up and Tag me in your reply I'll be happy to help. If this post helped you solve your issue please click Accept as solution and provide Thumbs Up. This will help others find it more readily.

@PG_WorXz10 thank you for the suggestion. However when I try to do this, the email contains a text document with just the item ID as the name and no data

@techtudoor in the run history of the flow did you get the correct file properties ? No data files are usually due to file extension or content mismatch.  

If this post was helpful or you need more help please consider giving Thumbs Up and Tag me in your reply I'll be happy to help. If this post helped you solve your issue please click Accept as solution and provide Thumbs Up. This will help others find it more readily.

@techtudoor 

It sounds like the same file will be attached all the time.  If so, add the ID column to a view of your library.  Make note of the ID of the document that you want to attach.

Then, follow my example below and let me know if you have any questions.  Don't worry that there is a loop - only 1 email will go out.

image.pngimage.pngimage.png

 

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

View solution in original post

@ScottShearer , thanks so much that worked great. I really appreciate the assistance

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Users online (1,392)