cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
noavb
Regular Visitor

Send email to people from people picker column

I created a document library and in it, a column named "Owners". I tied in SPO content approval with Flow.

I passed owners emails to a variable and if I use this variable to just send an email, it works fine.

When I use the same variable in "Assigned To" of "Start and wait for an approval", it gives an error.

 

The request failed. Error code: 'GraphLookUpRequestFailedError'. Error Message: 'User lookup request to Graph failed lookup for user identifier: '{"@odata.type":"#Microsoft.Azure.Connectors.SharePoint.SPListExpandedUser","Claims":"i:0#.f|membership|admin@sptat.onmicrosoft.com","DisplayName":"admin","Email":"admin@sptat.onmicrosoft.com","Picture'.'.

 

Screenshot 2021-09-04 184157.png

 

 

2 REPLIES 2
eric-cheng
Solution Sage
Solution Sage

Hi @noavb ,

 

Is the admin@sptat user part of your tenant?  Do you have other users in that list of approvers who may not be?

 

The email functionality works a little differently and doesn't validate whether the user is an actual user within your tenant.

 

--------------------------------------------------------------------------
If I have answered your question, please mark my post as a solution
If you have found my response helpful, please give it a thumbs up

Connect on LinkedIn

noavb
Regular Visitor

All users are from same tenant (sptat.onmicrosoft.com).

Actually, I did some trials, it seems Flow was not able to lookup any value in Assigned To field in Start and wait for an approval step.

I added admin@sptat.onmicrosoft.com and it still failed. I tried adding SPO group (thru variable) and that failed too.

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Users online (1,526)