cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
rlengacher
Frequent Visitor

SharePoint List Custom Action Flows No Longer Showing for a Selected Item

I have three SharePoint lists with instant flows to run a Custom Action for a selected item. Normal behavior is to select an item, right-click, hover over Automate (or click Automate above the list), wait a moment, and the custom action flow options appear. Yesterday afternoon, some no longer showed up. None of the flows were edited yesterday or today.

  • List 1: Normally there are 4 custom action flows for a selected item, now only 3 are showing.
  • List 2: Normally there is 1 custom action flow for a selected item, now 0 are showing.
  • List 3: Normally there are 5 custom action flows for a selected item, now only 1 is showing.

The right-click menu for a selected list item does not show all associated custom actions in the Automate section.The right-click menu for a selected list item does not show all associated custom actions in the Automate section.

5 REPLIES 5
jinivthakkar
Dual Super User
Dual Super User

@rlengacher if the flows where not changed then probably someone change the user permissions on the list. You need Edit/Contribute permissions to trigger flows for selected item.

 

--------------------------------------------------------------------------------
If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.

@jinivthakkar None of the permissions were edited on the list, so there may be an issue with my Microsoft 365 user information for the main connections on the flow (which I can't change).

I was able to work around this issue by giving run-only permission to the SharePoint list associated with each flow. I don't like that approach because different users on the same list need to see different options, but our team is small, so it won't be a big deal.

jinivthakkar
Dual Super User
Dual Super User

@rlengacher run-only permissions is the last resort, great if that works for you.

@jinivthakkar Could you point me to a thread or resource to that clarifies your comment "run-only permissions is the last resort"? I'm not sure if the last resort is assigning individual users as run-only users or assigning the run-only permission to the whole list.  I haven't marked my work around as a solution because I still don't know why some but not all of the flows randomly stopped showing.

jinivthakkar
Dual Super User
Dual Super User

@rlengacher there are only two things to check: 1. User permissions on list.   2. run only permissions.

 

thats what I was trying to say, there is no documentation or reference link. Hope you understand.

 

Helpful resources

Announcements
MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Power automate tips 768x460 v2.png

Restore a Deleted Flow

Did you know that you could restore a deleted flow? Check out this helpful article.

Users online (3,470)