cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
DaveBo
Level: Powered On

SharePoint Move File action

Hi,

The SharePoint Move File action fails to complete (no Outputs shown in the Workflow history)  no success or error message and does not move to next action,  although the move action does complete.  Any ideas why this might occur or workarrounds to ensure remainder of flow continues.

 

 

14 REPLIES 14
apples
Level: Powered On

Re: SharePoint Move File action

Same here. The action does actually work but we cant move to the next action. 

Community Support Team
Community Support Team

Re: SharePoint Move File action

Hi,

Could you share a screenshot of your flow?

Do you just want to get files copied/moved from one library to another?

Have you tried using the action Copy file?

I assume that this action should be able to meet your scenario. Please take a try with it.

1.PNG

 

Best regards,

Mabel

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
apples
Level: Powered On

Re: SharePoint Move File action

we need the move function becuase we are using it to archive a document and dont want to create duplicates.  The move function works but it doesnt complete the flow so we cannot action a next step :(.

Edit_your_flow___Microsoft_Flow.jpgManage_your_flows___Microsoft_Flow.jpg

 

 


@v-yamao-msft wrote:

Hi,

Could you share a screenshot of your flow?

Do you just want to get files copied/moved from one library to another?

Have you tried using the action Copy file?

I assume that this action should be able to meet your scenario. Please take a try with it.

1.PNG

 

Best regards,

Mabel


 

apples
Level: Powered On

Re: SharePoint Move File action

Edit_your_flow___Microsoft_Flow.jpgManage_your_flows___Microsoft_Flow.jpg

DaveBo
Level: Powered On

Re: SharePoint Move File action

I  have tested with Copy action and I see a similar problem -  copy is made -  but it does not move to the next action.

 

The move function was working last week.  I've raised a case with Microsoft.

 

Dave

 

 

Community Support Team
Community Support Team

Re: SharePoint Move File action

Hi @DaveBo@apples,

 

Thanks for feedback.

I have reported this issue on my side. I will back to you once I got any updates.

 

Best regards,

Mabel

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
TelmoC
Level: Powered On

Re: SharePoint Move File action

Hi, to overcome this problem , i am using the rest api, it seems to work

 

make an an http sharepoint post request to 

_api/web/getfilebyserverrelativeurl('/sites/logistics/<source path)/moveto(newurl='/sites/logistics/<target path>',flags=1)

 

 

 

 

DaveBo
Level: Powered On

Re: SharePoint Move File action

Hi, 

 

Microsoft have confirmed a bug and are working on fix to the problem.

 

Dave

PedroNeto
Level: Powered On

Re: SharePoint Move File action

Where did Microsoft say that? I have the same problem.

DaveBo
Level: Powered On

Re: SharePoint Move File action

Hi,  in response to the case I raised with them.  I will update here when I hear more.

Dave

 

DaveBo
Level: Powered On

Re: SharePoint Move File action

Hi All,

 

Informed by Microsoft this working again.   I've tested with the flow I was working on and all looks good now.

 

Dave

 

Re: SharePoint Move File action

Does this only work for new files created? What if I want to move existing files, has anyone tried to build a Flow for that? 

Re: SharePoint Move File action

Experiecing issues with this flow, is anyone else? We trigger the test but only see the spinning wheel with nothing happening in the folders we have linked too

Re: SharePoint Move File action

Ok so I managed to get this to work using the SharePoint areas for files in Teams - but the end user cannot get it to work linking to existing SharePoint sites, should this be the case? Any thoughts? The only error received when trying to execute the Flow was... 

 

Flow run timed out because the starting action was not performed. Please try again. 

 

Although the flow was triggered... has anyone else experienced the same? Or is this user error as the error suggests.

Helpful resources

Announcements
firstImage

Power Platform Online Conference

Join us for the first ever Power Platform Online Conference!

firstImage

Coming Soon: T-shirt Design Contest

Keep your eyes open for our upcoming T-shirt design contest!

firstImage

Incoming: New and improved badges!

Look out for new contribution recognition badges coming SOON!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Users online (6,516)