cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mmangiante
Helper V
Helper V

SharePoint list item update - error 404 - item not found

Hello,

 

I created a flow that do some action when I create a new item in a list; after some action, like send an email and create an event I try to update the list to fill 2 date fields, but I have a 404 error, item not found, as result.

 

These are the messages that I see (they are in italian, but I think is understandable):

 

{
  "Pragma": "no-cache",
  "x-ms-request-id": "21e4a841-97c8-4750-9a93-0b6ec814ce31",
  "Cache-Control": "no-cache",
  "Date": "Mon, 06 Mar 2017 11:25:35 GMT",
  "Set-Cookie": "ARRAffinity=bd234d641306dd3448fce384ea7a53bf259c53591cd1e441e64262d26c707c2b;Path=/;Domain=127.0.0.1",
  "Server": "Microsoft-IIS/8.0,Microsoft-HTTPAPI/2.0",
  "X-AspNet-Version": "4.0.30319",
  "X-Powered-By": "ASP.NET",
  "Content-Length": "266",
  "Content-Type": "application/json; charset=utf-8",
  "Expires": "-1"
}

 

{
  "status": 404,
  "message": "Elemento non esistente. È possibile che sia stato eliminato da un altro utente.",
  "source": "https://**bleep**kin.sharepoint.com/test//_api/web/lists/GetByTitle('Ferie%20e%20Permessi')/Items(44)",
  "errors": [
    "-2130575338",
    "System.ArgumentException"
  ]
}

 

Could you help me where I make the error?

 

--

Regards

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

Hello,

 

@avanidhar @v-yamao-msft I think I resolved the problem: I created the action but I signed in it with a different account than one used in the "When the new item is created".

 

I think Microsoft may resolve one of the problem that Flow has with the account and the us of generic account.

 

Thanks for your support.

 

--

Regards,

 

Marco Mangiante

View solution in original post

3 REPLIES 3
avanidhar
Power Automate
Power Automate

Hello,

 

How are you trying to update the list with the date fields? How are you identifying the rows to update?

 

Please let me know.

 

Avani

v-yamao-msft
Community Support
Community Support

Hi Mmangiante,

 

I assumed that you would like to create a flow looks like below:

1.png

 

Have you configured the Id field in the action “Update item”? if not, please try to select the ID from the Dynamic content when you configuring the flow to see if it works.

 

If convenience, please send me a screenshot of your flow configuration for better understanding.

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hello,

 

@avanidhar @v-yamao-msft I think I resolved the problem: I created the action but I signed in it with a different account than one used in the "When the new item is created".

 

I think Microsoft may resolve one of the problem that Flow has with the account and the us of generic account.

 

Thanks for your support.

 

--

Regards,

 

Marco Mangiante

View solution in original post

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Users online (1,361)