cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Helper I
Helper I

Sharepoint List Not Found

I connect to Sharepoint to move files into an Azure blob. This was working fine until one of the users changed the structure of Sharepoint.

 

Ive tried 

 

Site Address:  https://companyname.sharepoint.com/marketing/

This is fine because this worked before

Library Name: Marketing Analytics/OldFolder/OldSubFolder/

 

This is now not working and Im getting the error. But this is definitely the new file structuree, The only thing I can think of is that they have a space in Marketing Analytics. Could this be the problem.

 

Its frustrating because it definitely worked before when it was /OldFolder/OldSubFolder

 

If anyone can help that would be great

 

Thanks in advance

4 REPLIES 4
Community Support
Community Support

Hi @debbieedwards,

 

Could you share screenshots of your Flow configuration and details of the SharePoint library?

Could you provide a specific error message?

You could try to reconfigure the related action or entire Flow according new library Name.

Troubleshooting method:

  • Create a Get files(properties only) action, and then configure the corresponding library name to see if there is a corresponding value output.
  • Try to create a new library yourself, the library does not contain spaces, and then configure the relevant action to check if there are related issue.

Please provide more details and we would provide proper workaround for you.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

ListNotFoundError.GIF

And here is the full flow showing where the error is

FullListNotFoundFlow.GIF

And the error is

"status": 404,
"message": "List Not Found\r\nclientRequestId: 350535f2-ce33-4882-a9a6-b5e26ae684ea\r\nserviceRequestId: a04bb79e-00e2-0000-4ad6-b5ca36090f01"
 
I can certainly try 
  • Try to create a new library yourself, the library does not contain spaces, and then configure the relevant action to check if there are related issue.

By putting it back to how it was and checking that this still works. Im unsure what you mean in Point one though.

 

Ok here is the issue. If you add Sharepoint Get Files (Properties only) you only get Site address and Library Name

 

I went into the lowst folder in Sharepoint and Created a flow that would automatically connect and did a simple email task and I get this

SharepointFileAndFolder.GIF

Here you get the folder but the above task you only get Library Name. Is something wrong here? I need to add the folder to Get Files (Properties only) but where is the folder option?

Hi @debbieedwards,

 

I think I was misled by before, and the Library Name is Marketing Analytics.

"Marketing Analytics/OldFolder/OldSubFolder/" seems to be just folder.

It seems that you want to move the files in this folder path.

It is impossible to specify a folder in Get files action.

You could use Get files action first, then use Filter array to filter the files in the specified folder path.

Then use the contents of the Filter array output to configure the following action.

Like:

13.PNG

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Users online (9,489)