cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
MichalSiska
New Member

Sharepoint move file action fails but it does move the file successfully

Hello, I have a very simple flow which moves a file from one folder to another inside the same library on Share Point. I'm using the Move File action and use the "Identifier" value for the "File to Move" attribute obtained from the Share Point trigger:
MoveFile.png 

 

From time to time (approx. once a week) the flow fails with the following error:

{

  "status": 400,

  "message": "Failed to verify the existence of source object at 'https://xxx.sharepoint.com/sites/AP/Shared Documents/Invoices/approved/xxx.pdf' due to error 'The sy...

}

However, the file gets moved fine. Any idea why it's happening? 

 

I use the Move File action in anohter flow and it does the same thing - it occasionaly fails but moves the file fine at the same time.

 

Any help appriciated! Thanks!

2 REPLIES 2
kemppaik
Frequent Visitor

Did you get this figured out?  I'm having a similar issue.

MichalSiska
New Member

Hi, not really. I've slightly modified the flow so when it gets triggered it immediately moves the file to a read-only folder and the rest of the flow works against that folder (there is an approval step in the flow). Since then I haven't hit the problem as far as I remember.
That makes me think that someone must have been modifying the files after the flows got triggered. However, Sharepoint never indicated any activity on the files.

Helpful resources

Announcements
Power Automate News & Announcements

Power Automate News & Announcements

Keep up to date with current events and community announcements in the Power Automate community.

Community Calls Conversations

Community Calls Conversations

A great place where you can stay up to date with community calls and interact with the speakers.

Power Automate Community Blog

Power Automate Community Blog

Check out the latest Community Blog from the community!

Users online (4,257)